[SOLVED] Firefox Sync borks FF?

I did a new install of NR 13.06 earlier tonight & before I read anything I opened a terminal & did update/upgrade… oops maybe I should’nt?
I enabled Firefox with my sync credentials & FF became thoroughly borked.
I have since done a complete fresh install of NR 13.06 & did not do any form of update.
All seems very stable and fast.
Can I enable Sync without breaking FF again?

Chris

You can try enabling sync again. But I would advice using a new profile for this by executing

firefox -ProfileManager

Also notice that sync takes some time to sync all the bookmarks and settings.

Thank you!
I have a lot of experience using FF & sync’ing on Mac/Win/Lin.

I created a fresh new profile as per the above command & syn’d using my credentials.
Firefox is now behaving exactly as I would expect. Fast, stable & exactly matching my settings.

COMMENT :The default profile on the patched FF which NR ships in 13.06 seems much more ‘crashy’ than I would expect. My non-tech windows using friends are begging me to recommend a drop in replacement for Windows. I would highly recommend NR 13.06 to them but little niggles like this mar an otherwise perfect score.

Really appreciate your help.

Chris

Any specific crash you remember what might be at cause?

On a fresh install of NR 13.06 I launch FF using the default profile provided. FF crashs regularly & often when trying to view any and all web pages. Creating a new profile & sync’ing to mozilla’s server gives me normal stable operation.
This behavior is repeatable on 1 desktop & 2 laptops here.

I would like to help debug this. When I have a moment I will create a new test user account using the default FF profile.
Any suggestion how I capture useful information to submit?

Chris

My FF started crashing erratically again today for no discernible reason. Eventually it corrupts the user profile requiring a new profile & resync.

Launching FF in konsole i see : GLib-CRITICAL **: g_slice_set_config: assertion `sys_page_size == 0’ failed
Fontconfig warning: “/etc/fonts/conf.d/50-user.conf”, line 9: reading configurations from ~/.fonts.conf is deprecated

This is an old Firefox+Linux bug reanimated from what I can see :

https://bugzilla.mozilla.org/show_bug.cgi?id=833117

https://bugzilla.mozilla.org/show_bug.cgi?id=672671

https://bugs.launchpad.net/ubuntu/+source/firefox/+bug/1160569

https://bugzilla.gnome.org/show_bug.cgi?id=687763

https://bugzilla.gnome.org/show_bug.cgi?id=680831

Chris

Yeah it seems to be a bug thats not solved upstream.
Maybe using a fallback browser option like konqueror or rekonq would be wise until they fix the bug.

Careful reading of the bug indicates that the error messages are internal error messages not meant to be shown to the end user and supposedly not impacting the end user. I do see bug reporters complaining of problems despite the developers assurances. Probably these error messages are a ‘red herring’ in my case (see below).

After further cross checking I found that after removing the ‘Better Privacy’ FF extension from my FF sync profile FF returned to perfectly normal stable operation in Netrunner. Why does this extension cause problems in Netrunner and not in Windows/MacOS/other Linux distro’s? I cannot answer that. Just glad to have it working again.

I would humbly suggest to ship Netrunner version of FF as ‘plain vanilla’ sans customisations/extensions.

Regards,
Chris