[Solved] Installation problem: Installer crash during install

I’ve tried to install netrunner 14 LTS on my PC. I was not able to complete the installation procedure. It failed during the stage where it tries to copy packages. (after asking user details, after about 1 minute)

I’ve tried with both, install from a USB stick and install from a DVD. both times it failed the same way, saying something like “please file a bug report with the output from ubuntu-* ubiquity”. However when I tried to perform that command it failed saying that this package is missing and should be installed by “sudo apt-get install apport”. After installing this package, the said command reported “there is nothing to report”.

Is somebody able to help me here? I consider this to be a serious bug in the installer, as it makes it effectively impossible to install netrunner at all.
Booting the computer did not work after this procedure, although I think that significant portions of the packages were indeed already copied.

For the sake of completeness: I’ve also tried to install Linux Mint, the exact same failures happen there as well.

Mainboard Asus M5A99X EVO, AMD FX-8350, 16GB Ram, 500GB Harddrive, Graphics AMD Radeon HD 7970

As I’m writing this from another computer, I’m not able to copy any messages, or there may be errors/typos in the above specs.

Update, I’ve been able to solve the problem
I was finally able to install Netrunner from a DVD. The trick was to use “Netrunner, with Linux ..* (recovery mode)” in the grub selection menu.
The whole installation process was also slightly different as this time it gave me the option to select keyboard layout, where before there was a process that did crash and could be ignored.

Linux mint doesn’t use ubiquity so it can’t be an installer issue.

But it was the exact same installer and the exact same reference that was printed. Perhaps the “bug” is that the installer points to ubiquitiy anyway.

May I ask how did you create your Install medias?
It seems that Linux Mint now uses a hybrid ISO format which would need to be created with dd, mintstick, or something similar and NOT unetbootin or anything else that extracts the contents of the ISO to an existing file system, especially if your system has a UEFI bios.

Also make sure that if you are using a UEFI system that secure boot is disabled.

It’s funny that I seem to get only answers for Linux Mint in a Netrunner forum…

I’ve used YUMI to create the USB boot media. To reformat this USB media is currently not an option.
To date, I’ve tried the DVD image with Netrunner only.

The BIOS does not offer a selection to switch on/off secure boot.

What is the laptop make and model?
If it has a UEFI with secure boot and you can’t turn it off then Linux isn’t going to work on that laptop.

Ubuntu now uses a Hybrid ISO as well, but it’s hybrid structure is just a bit different than Mint’s.

It is not a laptop. read my first post:

And - If you’re correct and there is no way to install Linux anymore on a UEFI system - Why can I then boot up and run just about any Linux-Live image distro? I used to have debian running on this same machine the last 4 years…

OK then, what is the “computers” make and model? :slight_smile:

[bump] (see above…)

Do you had a big enough partition for it to install? How big was it?
Can you reproduce the error? Did you tried installing again?

When the installer fails there should be an installer log in /var/log that could help us understanding what went wrong

This is not a UEFI problem, it’s a secure boot problem. if you don’t have the correct signatures then it won’t be able to be installed and run from the internal hard drive. You need to be able to either turn off secure boot in the UEFI or install Linux using the legacy (BIOS) mode if available.
Look here: http://www.netrunner-os.com/faq/installation/

I’ve had a look at this page, but i doubt that UEFI or secure boot had anything to do with the problem. I was finally able to install, but the trick was using “(recovery mode)” during grub menu. I’ve updated the title of this thread and also put the description in the first post.

Nevertheless, I think there is a “bug” in the installer, as this guy sends the users astray searching for the bug in an application with is not even used on Netrunner…
There is also a “bug” in the Documentation: The Installer page should IMHO be updated to:
[]describe the DVD install as the first option, as you less likely have the option of (rescue mode) with a usb drive
]point users to the (rescue mode) option in the grub menu if a first attempt to install fails at some point
Can somebody point me to the correct place to file bugs?