[SOLVED}Installing Chrome

Right off I like Netrunner Rolling, alot. It’s just what I’ve been looking for, except. . .

I’ve spent hours trying to figure out how to get Chrome installed! Nothing seems to work, either using instructions from the net and terminal commands or using Octopi (Which wants me to edit).

Not having Chrome is a deal breaker and I’m about to give up and move on but someone must have figured out how to do this, I really would like to use NR.

The command

sudo yaourt -S google-chrome

In the terminal should work.
If it asks to edit something say no and it will continue.

This is actually and easy one, I run google-chrome on my systems as well:
When your asked if you wish to edit the pkgbuild file hit N, you only need to edit that if there is a specific reason to, then when it asks if you want to edit the google-chrome.install file, again hit N, for the same reason as before, now when it asks if you wish to continue building hit Y, at this point yaourt will download the deb package from Google, dpkg it in a chroot environment and then make a google-chrome.pkg.tar.xz file from it’s contents that can be installed with pacman, and finally hit Y to install the resulting package, that’s all there really is to it.

PS, The AUR doesn’t need to be scary if you don’t let it. :slight_smile:

You guys rock! Much easier than what I’ve been trying. Knowing not to worry about the editing was key.

And now we have an easy “solve” for the next new runner!


You can add the solve tag by editing the title of your initial post and simply add [solved]

Just a FYI, when installing programs from the AUR there will be times when editing the PKGBUILD and/or **.install files will be necessary, but for the most part just hitting N works.

When I tried this yaourt advised me ‘–asroot’ is an invalid option.
I tried without sudo and it installed nicely.
Evidentially yaourt can be a very handy tool.


(aka timber)

Yes, yaourt is a handy tool, it is a wrapper for pacman that enables you to search and install applications from the AUR as well as the official repositories. Octopi also allows you to do this as well, to search the AUR you only need to hit the alien icon next to the search bar, type in the program you want and hit enter. With this method I find it easier to review the search results than using yaourt -Ss {program name}. :wink: