[Solved] KDE Power Management System error

Hi,

Im a newbie with Linux, just been using Mint and Ubuntu for the last 9 months. So I still have a long way to go , so pls be kind with your comments :wink:

I was getting tired with Mint and wanted something new, and thus decided to give Netrunner a try.
After installing it on my laptop it looked very promising and I couldnt wait to start customizing.
To my regret Netrunner seems to have some bugs,
so I would really appreciate any constructive comments to help fix them.

Will try and break it down as quick and easy as possible.

Im running Netrunner 14 Frontier, 64 bits on my Asus laptop.

When I run the “system update” on a fresh installment, it starts fine, but after some have been downloaded and installed i get a “failed to download” error and the update stops.
I then restart my computer.
When I log in my: wifi / network / usb / restart button / shutdown button have stopped working.
I get the following error message:

"KDE Power Managment System could not be initialized.
The backend reported the following error.
No valid Power Management backend plugins are available.
A new installation might solve this problem. "

When I go to System Settings -> Power Management , it is locked and nothing can be changed.
And as nothing works I cant run another update, or even restart. When i force shutdown it restarts with the same error.

Could anyone pls help to advise which updates that are causing this problem, so I can avoid them.
In attachment all updates available are shown.

As Netrunner seems to be a distro suitable for me I would really appreciate if you could help with this problem.
Really thought a clean installment would be able to run an update though :confused:

Thx

It sounds to me like you started an update without refreshing the update list.
Maybe thats the reason it fails to download stuff and that is causing the issues you describe.

So either hit refresh on the update manager or execute the following in a terminal.

sudo apt-get update && sudo apt-get upgrade

It should upgrade then fine and your problems should be gone.

Thx for your quick reply.

I tried sudo apt-get update && sudo apt-get upgrade
It downloaded 464 files and then had “Failed to fetch” for some, thus never installing anything at all.
I ran “sudo apt-get update && sudo apt-get upgrade” one more time to see the result.

Reading package lists… Done
Reading package lists… Done
Building dependency tree
Reading state information… Done
Calculating upgrade… Done
The following packages have been kept back:
linux-generic linux-headers-generic linux-image-generic vokoscreen
The following packages will be upgraded:
accountsservice akonadi-facebook akregator apparmor apt apt-transport-https
apt-utils aptdaemon aptdaemon-data ark audiocd-kio baloo bash bsdutils
.
.
. (the list of all 464)
464 upgraded, 0 newly installed, 0 to remove and 4 not upgraded.
Need to get 1 984 kB/419 MB of archives.
After this operation, 17,4 MB of additional disk space will be used.
Do you want to continue? [Y/n] y
Get:1 http://archive.ubuntu.com/ubuntu/ trusty-updates/main libkrb5support0 i386 1.12+dfsg-2ubuntu4.2 [30,1 kB]
Get:2 http://archive.ubuntu.com/ubuntu/ trusty-updates/main libkrb5support0 amd64 1.12+dfsg-2ubuntu4.2 [29,8 kB]
Get:3 http://archive.ubuntu.com/ubuntu/ trusty-updates/main libgphoto2-port10 amd64 2.5.3.1-1ubuntu2.2 [40,8 kB]
Get:4 http://archive.ubuntu.com/ubuntu/ trusty-updates/main libreoffice-pdfimport amd64 1:4.2.7-0ubuntu1 [220 kB]
Get:5 http://archive.ubuntu.com/ubuntu/ trusty-updates/universe libreoffice-report-builder-bin amd64 1:4.2.7-0ubuntu1 [777 kB]
Get:6 http://archive.ubuntu.com/ubuntu/ trusty-updates/main multiarch-support amd64 2.19-0ubuntu6.3 [4 484 B]
Get:7 http://archive.ubuntu.com/ubuntu/ trusty-updates/main apt-transport-https amd64 1.0.1ubuntu2.6 [25,1 kB]
Get:8 http://archive.ubuntu.com/ubuntu/ trusty-updates/main libkde3support4 amd64 4:4.13.3-0ubuntu0.1 [295 kB]
Get:9 http://archive.ubuntu.com/ubuntu/ trusty-updates/universe libmailtransport4 amd64 4:4.13.3-0ubuntu0.1 [141 kB]
Get:10 http://archive.ubuntu.com/ubuntu/ trusty-updates/universe libmailimporter4 amd64 4:4.13.3-0ubuntu0.1 [109 kB]
Get:11 http://archive.ubuntu.com/ubuntu/ trusty-updates/universe libcalendarsupport4 amd64 4:4.13.3-0ubuntu0.1 [228 kB]
Get:12 http://archive.ubuntu.com/ubuntu/ trusty-updates/main python3-problem-report all 2.14.1-0ubuntu3.5 [9 098 B]
Get:13 http://archive.ubuntu.com/ubuntu/ trusty-updates/main python3-apport all 2.14.1-0ubuntu3.5 [74,9 kB]
Fetched 8 437 B in 1s (4 830 B/s)
E: Failed to fetch http://archive.ubuntu.com/ubuntu/pool/main/k/krb5/libkrb5support0_1.12+dfsg-2ubuntu4.2_i386.deb Size mismatch

E: Failed to fetch http://archive.ubuntu.com/ubuntu/pool/main/k/krb5/libkrb5support0_1.12+dfsg-2ubuntu4.2_amd64.deb Size mismatch

E: Failed to fetch http://archive.ubuntu.com/ubuntu/pool/main/libg/libgphoto2/libgphoto2-port10_2.5.3.1-1ubuntu2.2_amd64.deb Size mismatch

E: Failed to fetch http://archive.ubuntu.com/ubuntu/pool/main/libr/libreoffice/libreoffice-pdfimport_4.2.7-0ubuntu1_amd64.deb Size mismatch

E: Failed to fetch http://archive.ubuntu.com/ubuntu/pool/universe/libr/libreoffice/libreoffice-report-builder-bin_4.2.7-0ubuntu1_amd64.deb Size mismatch

E: Failed to fetch http://archive.ubuntu.com/ubuntu/pool/main/e/eglibc/multiarch-support_2.19-0ubuntu6.3_amd64.deb Size mismatch

E: Failed to fetch http://archive.ubuntu.com/ubuntu/pool/main/a/apt/apt-transport-https_1.0.1ubuntu2.6_amd64.deb Size mismatch

E: Failed to fetch http://archive.ubuntu.com/ubuntu/pool/main/k/kde4libs/libkde3support4_4.13.3-0ubuntu0.1_amd64.deb Size mismatch

E: Failed to fetch http://archive.ubuntu.com/ubuntu/pool/universe/k/kdepimlibs/libmailtransport4_4.13.3-0ubuntu0.1_amd64.deb Size mismatch

E: Failed to fetch http://archive.ubuntu.com/ubuntu/pool/universe/k/kdepim/libmailimporter4_4.13.3-0ubuntu0.1_amd64.deb Size mismatch

E: Failed to fetch http://archive.ubuntu.com/ubuntu/pool/universe/k/kdepim/libcalendarsupport4_4.13.3-0ubuntu0.1_amd64.deb Size mismatch

E: Failed to fetch http://archive.ubuntu.com/ubuntu/pool/main/a/apport/python3-problem-report_2.14.1-0ubuntu3.5_all.deb Size mismatch

E: Failed to fetch http://archive.ubuntu.com/ubuntu/pool/main/a/apport/python3-apport_2.14.1-0ubuntu3.5_all.deb Size mismatch

E: Unable to fetch some archives, maybe run apt-get update or try with --fix-missing?

The exact same thing happens if I run it a 3rd time. I also restarted the laptop and ran again but with the same result.
How do I move from here?

That’s strange indeed. There is a whole thread about that issue: http://www.linuxquestions.org/questions/debian-26/apt-get-size-mismatch-431918/

First I would recommend running

sudo apt-get clean and try again updating.

If this does not work try the suggestions in the thread linked above.

PS: please use quotations for pasted text in the future otherwise akismet might autoban you

This sounds like a mirror problem, but this could be a file system issue.
What file system are you using?

I tested that mirror and it is working fine. I fear that it’s an ISP related problem.

If your problem is a file system issue, you might try using eatmydata to disable the fsync. etc. while running apt:

sudo eatmydata apt-get update && apt-get upgrade

You might need to install eatmydata first though, I’m not sure if it’s installed by default on Netrunner.

http://manpages.ubuntu.com/manpages/precise/man1/eatmydata.1.html
http://packages.ubuntu.com/search?keywords=eatmydata

Im using the default setting ext4.
Have attached screenshot with specs.

Seems to be affecting Muon Discover as well.
Tested to download some regular programs , all started to download but then some “Could not download packages”.
For example GParted, Audacious worked fine to install. Deluge and Audacity did not.

I tried “sudo apt-get clean” and then ran “sudo apt-get update && sudo apt-get upgrade” again.
Same result.

Then i installed eatmydata through your link , went to root and ran " sudo eatmydata apt-get update && apt-get upgrade".

Same result as before, “failed to fetch …”

Could you possibly be behind a proxy?
If your behind a proxy that is caching this could also be the issue.

http://ubuntuforums.org/showthread.php?t=1728894
http://ubuntuforums.org/showthread.php?t=1980362

Yes Im behind a proxy so you might be right. But:

  1. Wouldnt the proxy have stopped the downloads while I was using Mint?
  2. Can the proxy be related to the KDE Power Management System error?

Anyway, I will be on a proxy free network on monday I will try out your advises…

All the help you have provided have been commands for the terminal.
But as a newbie I was using Muon Update Manager when the Power Management error occured.
Is it possible the issue can be with that?
While using the terminal commands I have not had the error yet.

Yes, it very possibly could be, sometimes the command line tools just work better then the GUI Software equivalents.

Keep in mind that Muon Update Manager and Mint Updater are two completely different GUI tools, which don’t have exactly the same features or functions.

I ran the update with eatmydata and without the proxy and could download everything.
Still got some strange “unknowns” im not sure what they mean , but the installation went through successfully, and i could reboot without the previous issue.

“Processing triggers for hicolor-icon-theme (0.13-1) …
Processing triggers for shared-mime-info (1.2-0ubuntu3) …
Unknown media type in type ‘all/all’
Unknown media type in type ‘all/allfiles’
Unknown media type in type ‘uri/mms’
Unknown media type in type ‘uri/mmst’
Unknown media type in type ‘uri/mmsu’
Unknown media type in type ‘uri/pnm’
Unknown media type in type ‘uri/rtspt’
Unknown media type in type ‘uri/rtspu’
Processing triggers for man-db (2.6.7.1-1ubuntu1) …”

So think this thread can be closed.
Thanks AJSlye and leszek for your help.
Netrunner looks great so far. Really satisfied with it.

Those unknown lines are from the configuration of the mimetypes.
There are some mimetypes that application want to register that are unknown to the system simply speaking.
These you can just ignore.

Can you mark this problem as solved by editing the title of your initial post and adding [solved] to it.