[SOLVED] No automatic switch between headphones and speakers

When the laptop plays on speakers and I plug the headphones in the laptop goes mute, but there is no sound in the headphones. I have to use the volume control app (or System Settings Audio menu) to set it automatically using connector drop-down list.

It worked fine on Netrunner 14 .

I’ve seen this post:
but my laptop does not play any bios beep…

Laptop: Lenovo Yoga 2 Pro
System: Linux 4.2.0-19-generic x86_64
Boot using UEFI
Plasma: 5.4.3
Audio Backend: Phonon

I had Clementine briefly installed.

I’ll accept how to link the speaker-to-headphone switch with a button as a workaround. It can use xbinkeys :wink:

I only once heard about this problem on a old macbook.
What solved the issue there was a alsamixer switch that had to be turned on.

Can you execute alsamixer -c 0 in a terminal and see under the all tab if you can turn something on there that can help you solve your problem. As I don’t know how this option might be called can you maybe try all switches that are there one by one and see if it improves the situation.
I hope you can find the right one and that it works afterwards.

Each time I enter alsamixer it look like that. Even when I switch the card (F6 in alsamixer):
Doesn’t matter what I change, do I use sudo or not.

How can I set audio setting to default?

Yeah it seems to be only grabbing the hdmi output and not the real sound card.

sounds strange as it should at least somewhere have the normal audio settings.
Are you sure you tried every sound card listed there ?

Can you try setting things up with pavucontrol

I did that too! This is the place where switching between headphones and speaker is the most convenient but fully manual

Can you try uncommenting the line

# load-module module-switch-on-port-available


load-module module-switch-on-port-available

in /etc/pulse/default.pa. You need root rights for that.
After that please restart and test again.

Hurrray! Thanks Leszek! That did the job! I’m marking the threat as SOLVED.

Just want to add (for people searching) that uncommenting that line worked for my Lenovo Z70, too. Thanks for the easy fix for an annoying little problem.

Wow… I must say I’m impressed with the new sound device managing in N-17! The system remembers now what volume was set for loudspeakers and headphones separately. :slight_smile: