[Solved]Steam error after update.

Hi everybody!

I just installed. I was poking around while updates were installing, and steam/dota 2 worked great. after the updates were done, I was unable to use dota 2. Steam works, but only until I start dota 2. I get this error right when I start steam.

“OpenGL GLX context is not using direct rendering, which may cause performance problems.”

Here are the two threads I have google’d so far.

https://bbs.archlinux.org/viewtopic.php?pid=1420792

https://bbs.archlinux.org/viewtopic.php?id=181679

I am not really sure what to do. People said to remove a file in a certain location for a workaround, but I can’t find it. I have searched with the search function and tried looking manually.

Ok, I solved this problem as I was writing this post. I think I will leave it here anyway, or delete it? up to the mods. Don’t mean to spam, but here is what I did.

I typed this into the console

find ~/.local/share/Steam -name ‘libstdc*.so*’ -delete
find ~/.local/share/Steam -name ‘libgcc_s*.so*’ -delete

Thanks!

Thanks that might be indeed very useful.

This WAS a known problem, and has already been fixed by the Manjaro team, you’ll need to install the steam-native package after you run all system updates:

sudo pacman -Syyuu
sudo pacman -S steam-native

Package description:

Netrunner Rolling is based on Manjaro and not Arch itself so please keep in mind that some parts of the Manjaro system are different from those of Arch, you must be careful when using advice posted in the Arch wiki or forums.

Besides this forum, you can also get help in the Manjaro forums as well, you can also use the Manjaro wiki & blog for news and advice:
http://forum.manjaro.org/
https://wiki.manjaro.org/

PS. Do NOT ask for help with or mention Netrunner Rolling/Manjaro in the Arch forums they will NOT help you, it’s in their forum rules.

Ok, I will play with this soon.

Edit: I ran those commands, everything is still smooth. I have heard they really don’t like it when people do that, i’ll stay clear of those forums.

Thanks for the help!