back to Netrunner | back to Blue Systems

(SOLVED) Update-grub does not see the kernel


#1

Hello,

I’m dealing with a new (to me) spin on a common situation.
I’m a dual-boot user, running Windows 10 and Netrunner Core, with the latter being my main operating system.
My laptop is set to boot in legacy mode, my drive is partitioned using an MBR table.

After a few months of ignoring it, I recently started dabbling with Windows again, run a few updates, installed some game, and bricked the system. I was hence forced to reinstall Windows 10, so far so good.
I then proceeded to look up the instructions to reinstall grub to be able to boot into Netrunner again. Last time I did this, it went perfectly, recovering my bootloader exactly as it was. This time I must have followed different instructions, because when restarting I discover that only Windows appears as an option (and that the beautiful netrunner theme for the bootloader is not there).

I tried fixing this, but every time I would result in the same situation. Finally, I got tired, and from the grub interface I pressed C, and loaded up Netrunner by manually typing

set root=(hd0,msdos5)
linux /boot/vmlinuz-4.19.0-8-amd64 root=/dev/sda5
initrd /boot/initrd.img-4.19.0-8-amd64
boot

Back into netrunner, I went to reinstall grub in /dev/sda, and run update-grub and… it only sees Windows 10!
Here is an example

root@fernando-dell:~# ls /boot
config-4.19.0-6-amd64  config-4.19.0-8-amd64  grub  grub_backup  grub.bak  initrd.img-4.19.0-6-amd64  initrd.img-4.19.0-8-amd64  System.map-4.19.0-6-amd64  System.map-4.19.0-8-amd64  vmlinuz-4.19.0-6-amd64  vmlinuz-4.19.0-8-amd64
root@fernando-dell:~# update-grub
Generating grub configuration file ...
Found Windows 10 on /dev/sda1
done

As you can see, I do have a couple of versions of the kernel, which I can use to manually boot into Linux, but update-grub just won’t see them.

I did try to purge my grub installation by running the following, but it results in the same situation.

sudo apt-get purge grub grub-pc grub-common
sudo mv /boot/grub /boot/grub_backup
sudo mkdir /boot/grub
sudo apt-get install grub-pc grub-common
sudo grub-install --recheck /dev/sda
sudo update-grub

I am a little unsure on how to proceed. I really don’t want to reinstall the whole OS.

Cheers
Fernando

Edit: formatting.


#2

Hi,

I solved my situation. Apparently at some point, some of the instructions/tools (boot-repair) that I used to “fix” by grub deleted /etc/grub.d/06_netrunner_theme and, crucially, /etc/grub.d/10_linux.

I figured it out by installing Core into a vm, and using meld to compare /boot and /etc/grub.d.

I will mark the thread as solved in the title.

Cheers
Fernando