[solved] USB boot = nvidia graphics problems

On an older nvidia machine I get black screens or diagonally scrambled graphics.
I checked mdsum and used usb creator to make the usb.

I’ve tried compatibility mode, added nomodeset and a few other options.

The farthest I’ve gotten is after the Ozymandias stone screen… I get the welcome music and then diagonally scrambled graphics.

On this same machine, when I installed netrunner rolling, my notes say “had to select non-free drivers or else I get blank screen” but that same option doesn’t show up on netrunner 16.

Other suggestions?

Thanks, Bill

Well, I saw a combination on Linux Mint’s installation notes: On the default boot option change these options:
delete “quiet splash --”
add nomodeset

That got me to the desktop.
So all looks OK. Installing now…

Netrunner Rolling is based on Manjaro (Arch derivative) which would be ahead of Ubuntu in software, drivers, etc. So Yes, Netrunner Rolling would have been using newer drivers than Netrunner 14 or 15, Netrunner 16 has temporarily caught up in this regard as far as the current Install ISO’s are concerned, so the same Issue and solution would apply.

more reports in case it can helps someone else with nvidia issues:
Installed NR 16, and on 2 reboots, I got to the KDE login screen (with the Pharoah background) …as soon as I hit the first character of password, I got blank screen with an “x” cursor that would move with the mouse - nothing else would happen.

Reboot into recovery mode option at grub screen, and eventually when I got the KDE login screen, the login worked.
From K-Menu, >>> Settings >>> Additional drivers >>> Selected nvidia and apply
From there reboots worked OK.

Sounds like your nvidia chip is a newer one that requires the proprietary driver to work properly, this is actually normal. Unlike the Intel opensource drivers that are developed by Intel or the ATI/AMD opensource drivers that have support from AMD, Nvidia still refuses to help out with any opensource development. The opensource nouveau driver has to be reverse engineered for every chip set that nvidia releases, this makes it take longer for the developers to support the newer graphics chips.

I thought it is a fairly older nvidia card:

inxi -G Graphics: Card: NVIDIA C61 [GeForce 6100 nForce 405] Display Server: X.Org 1.17.1 drivers: nvidia (unloaded: fbdev,vesa,nouveau) Resolution: 1440x900@59.9hz GLX Renderer: GeForce 6100 nForce 405/integrated/SSE2 GLX Version: 2.1.2 NVIDIA 304.125

Anyway, From K-Menu, >>> Settings >>> Additional drivers >>> I had chosen the “recommended” driver, but I was still having really bad performance and minor graphic hickups.

I went back to Additional drivers and chose the “alternate” (I think that what it said, not 100% sure maybe it said “updates” - I don’t remember seeing the word “proprietary”) and THEN it installed the proprietary nvidia driver and now all seems well.

The biggest problem I had was having to find out that to boot the USB I had to use these options
delete “quiet splash --” add nomodeset; …whereas netrunner rolling had a super-easy “use non-free” driver choice.
Once running, install the alternative/proprietary nvidia driver. After installing, make sure Additional drivers screen looks like attached screenshot with ‘nvidia-304-updates’ proprietary driver.