[SOLVED via workaround] sambamounter glitch

Following the video here:

I attempted to set up my goflex NAS via the samba mounter.

The result is that the folder is created in Home/critter/network but remains empty. I’ve tried both with and without passwords, etc.

I can navigate through the usual samba shares network and access the drive, play vids from it, etc, but it just doesn’t display contents via Dolphin and the newly created sambamounter shared folder

Here is a split view of Dolphin. The left is the sambamounter folder, the right is navigation to the NAS drive through the usual network interface. DivxMovies shown on the right is a subdirectory of DigitalMovies (left) which isn’t showing up in the left pane under the top folder of the share:


screenshots of the config



Seems like I’m missing something simple but can’t figure out what that is.

Hi critter,

can you delete the sambamounter entry, close sambamounter, and add a new connection again, but with the IP adress instead?

I guess the samba mounter failed to mount the location.
To be sure please execute

in a terminal and see if the samba share is listed there.
If it isn’t then samba mounting just simply failed which is interesting as it should give an error message.

Thanks for the replies.

OK, the goflex is definitely resisting the mounting process (IP as well). Perhaps its a virgin. The problem is isolated to something unique to the goflex…

I have another, Lenovo IX2-200, for which the sambamounter mounts any folder on the NAS just fine. I’ll dive into the configs and see what I can find. The immediately obvious differences are that the goflex requires username/password while the IX2 does not, and there are spaces in the share path of goflex, but there could be something else buried in the configurations.

Another question:

Here is the (correctly) mounted NAS info…

// on /home/critter/Network/Documents type cifs (rw,relatime,vers=1.0,sec=ntlmv2,cache=strict,domain=WORKGROUP,uid=1000,forceuid,gid=0,noforcegid,addr=,unix,posixpaths,serverino,acl,rsize=1048576,wsize=65536,actimeo=1)

As mentioned, this one is functioning fine. The above indicates the domain=WORKGROUP. That’s not the name of my network here. Where is that name coming from? Is that an internal default or have I missed a system setting somewhere in NR?

It is the default workgroup set in samba. I am not sure if you are able to change it though.
I don’t think editing /etc/samba/smb.conf (search for workgroup and set it there) will help much. But you could try it.
All in all that should not have any big effect on the mounting though.

Previously on “GoFlex Possessed”…

That’s interesting. I checked the smb.conf after noticing WORKGROUP and became quite curious because the network file sharing works perfectly between all PC’s, both Win and Linux, so you’re correct that the smb.conf doesn’t appear to have an effect on the mount itself.

server string = CritterBox
workgroup = EMPIRE
netbios name = critter
security = user
encrypt passwords = yes
guest account = nobody
name resolve order = bcast host
unix extensions = no
wide links = yes
include = /etc/samba/smbshared.conf

Not really a major problem anyway, rather just more of a curiosity now as to what’s actually going on with this thing, because I can create an access link by using the “Add Network Folder” link here:


Is it possible that the sambamounter simply isn’t storing the password? I ask this because the “Apply” button never becomes active during the process and I receive no error msg at all and it doea appear to mount. Save and/or OK are active, and either one creates the folder under /home/critter/network.

I haven’t tried mounting goflex through fstab yet. Local drives are easy but I need to read up on how to mount network drives that way (translation: I have no idea how to do that yet).

Alrighty then…

I think (perhaps, maybe, possibly) the problem may be related to the spaces in the share path. I cannot verify this possibility due to the hard coded top level folders on the GoFlex. I can’t create a new top level folder such as “test” to attempt the mount on that rather than “GoFlex Home Public”. Perhaps this is not the problem at. Just a guess because…

I successfully mounted the share using fstab and needed to escape the spaces with \040:

# Network Mounts
//\040Home\040Public/DigitalMovies /media/DigitalMovies cifs credentials=/home/critter/.smbcredentials,iocharset=utf8,sec=ntlm 0 0

At any rate, the share is mounted which makes using movie subtitles less complicated as for some reason VLC won’t allow the use of subtitles on a remote partition (they must be “local”).

If someone else runs into a similar problem, the steps are fairly simple as summarized here for my situation…
first create your mount point directory (in my example “DigitalMovies”)

mkdir /media/DigitalMovies

if your share requires username/password then create a hidden credentials file in your home/username folder, e.g., /home/username/.smbcredentials which contains only


Change the permissions of the file to prevent unwanted access to your credentials:

chmod 600 ~/.smbcredentials

then edit your /etc/fstab with root permission adding your mount particulars (similarly to mine above)

set up:

dealing with spaces in the path:

The share is mounted and working now and PLEASE correct me here if something is amiss, or offer suggestions for a more efficient way of doing this.

EDIT: forgot to mention - prior to the fstab mount, I also deleted and attempted to create with escape code \040 in the path spaces within sambamounter, but the result was the same as before. It still didn’t mount properly…

Follow up info:

Well, that worked for a couple of restarts, then failed to mount at boot (with the failed error msg). Then worked again. Then failed again. Ooookay… Perhaps there’s an intermittent timing problem in the boot sequence for network mounts. What’s actually happening during the boot process? Seems that a condition of mounting a network drive should be that the network be up and running first. But perhaps there’s something else.

Anyway, I found a solution which is to have the system mount the drive on first access. From the user perspective there’s little noticeable difference aside from perhaps a (very) short delay (I didn’t really notice a difference at all) with the first click.

this needs to be added to mount line in /etc/fstab


so the line became:

//\040Home\040Public/DigitalMovies /media/DigitalMovies cifs noauto,x-systemd.automount,credentials=/home/critter/.smbcredentials,iocharset=utf8,sec=ntlm 0 0

Another possibility is to add a delay timer to give the system a chance fire up the network. I prefer the above method for what I needed to accomplish.