[SOLVED] X segfaulting after upgrade (OsLookupColour+0x139)

Hi there,

I’ve just switched to Netrunner, so please excuse me if I’m ignorant about how to figure out stuff on this system :slight_smile:

I’ve installed Netrunner Rolling 2015.11 on my i915-based Zenbook Prime. This worked fine, but as soon as I do

sudo pacman -Syu

to upgrade the system, my X configuration breaks. I can boot into the desktop manager (sddm, right?), but as soon as I enter my password and hit ENTER, X will crash and drop me into the login screen again. From the previous session’s Xorg.0.log, I can see that I’m hitting an instance of the same bug that has been reported for Fedora before:


I’ve tried using mhwd to switch to the pure intel driver, to no avail. I was able to restore working X funktionality by changing:

Driver "intel"


Driver "modesetting"

in the Device Section of my Xorg config. However, this way I loose AIGLX / Composite and probably any kind of hardware accel, too.

[]Has anybody seen this kind of issue before? Maybe even know a fix?
]How can I figure out which package’s upgrade caused this issue? Can I do some trial-and-error downgrading to bisect the offending change?



There is a fix currently in testing for now add or change this line to option “DRI” “3”.

Thanks for the fix. While this allows me to actually start the KDE session without X segfaulting, the driver still seems to be badly broken - screen regions don’t get updated or get updated incorrectly when switching windows, for example. So Driver “modesetting” seems to be the better option for now.

After the last upgrade to xf86-video intel, everything works perfectly.