SSH server problem with automatic start

Hi everyone, this is my first post, and I hope to enjoy the community ,like the fantastic netrunner:D.
Let’s start with the problem: I installed on my machine the openssh server because I need to access it even when I’m not at home. I configured everything ,and all seems to be fine, except for one thing: when I reboot my machine and I try to connect to the ssh server I get the “connrefused” error; to make it work I have to manually run “sudo service ssh restart” .
Anyone could explain me the reason , and if there is some workaround to avoid this everytime I reboot my machine?

Netrunner 14 (standard) is based on Ubuntu, this is what you need:

Just remember to use kate instead of gedit.

That is really strange. Can you see any error in the boot.log that shows why it does not want to start at bootup?

@AJSlye : I’ve already configured SSH server.
@leszek: in boot.log there isn’t any error regarding the server because it starts correctly.

  • Starting OpenSSH server^[[169G[ OK ]

Nobody could help me with this problem???

I’m not sure about leszek, but on my Netrunner 14 computer I could not reproduce the issue.

I’m not familiar with how the standard edition (kubuntu) handles power management, but could it be possible that the network adapter is going into sleep mode and not waking up when you try to ssh in, or could this also be a firewall issue?

I wasn’t able to reproduce it either.

I’m not familiar with how the standard edition (kubuntu) handles power management, or the firewall for that matter, but could it be possible that the network adapter is going into sleep mode, and not waking up when the user tries to ssh in?

I use connectbot on my android phone to connect the ssh server , maybe tomorrow i’ll try to connect with a different app and let you know if something changes :smiley:

I’ve just tryied with juice ssh , but same problem. How could I set the acpi on netrunner? I found something in the system settings but regarding the screensaver and the monitor ,nothing else

I meant the network adapter in the ssh host server is going to sleep and not waking up on external connections, so either wake-on-lan is not working in you power management set up or you have a firewall blocking the incoming connection. However, since walking over to the host computer and restarting ssh works, I’d suggest looking at the power management settings on the computer that is hosting the SSH server.

I am not that linux savvy and I don’t know if this is relevant but for example to make kdeconnect work -with ufw enabled - had to make a rule to allow ssh .

If it is a power management problem ,are you using TLP or something like that?

Netrunner Rolling (Manjaro) usses TLP, I’m not sure what Netrunner Standard (Kubuntu) uses.

Netrunner Standard uses laptop-mode-tools.

How could I check my acpi configuration??

TLP commands:

sudo tlp -h

for the entire TLP information stack:

sudo tlp-stat

Or you could Install the acpi client:

sudo pacman -S acpi


acpi -V

This is a good read:

thank you all for the answers, I decided to upgrade the kernel and try to dig inside the acpi settings, but I was wondering if I can use normal ubuntu kernel in Netrunner. I found this page
Do you think this is going to work?DO you have better solution?

Does Netrunner not use the Kubuntu (Ubuntu) kernels already?

Wouldn’t you only need to enable the Ubuntu and/or Kubuntu backports repositories to receive updated kernels?

I’ve already enabled the kubuntu backports repos, but the only available kernel is the 3.13 , I need at least 3.14 to enable more acpi features, hoping to solve my issue

OK, then in that case you can use any of the mainline kernels:

Also no one stops you from getting the utopic kernel from the 14.10 repository.