TeamViwer

[attachment=51][attachment=52]Hi,

I recently installed Netrunner 13 and everything went fine. I installed TeamViewer 8 64bit and upon launch it simply hangs. I tried the 32bit version and still won’t run. this is also the same for versions 7 & 6.

Please help.

Thank you

The new teamviewer needs a reboot as far as I am aware to start its daemon in the background. Have you rebooted your machine after installing ?

Hello, yes I have.
[hr]

teamviewer comes with wine 1.2.1 and netrunner has 1.6 as a default not sure if there is a relation.

Perhaps its having problems detecting the msttcorefonts.
Try reinstalling them with

sudo apt-get install --reinstall ttf-mscorefonts-installer

Hello leszek, I ran the command, it went well without errors. ran teamviewer but unfortunately still the same. I rebooted as well same issue.

I have the same problem.
I cant get past the License agreement screen/window…

Please try start the application from the command line in a terminal and post the output as quote in here.

Hi, here it is

Init…
Checking setup…
Launching TeamViewer…
fixme:service:scmdatabase_autostart_services Auto-start service L"MountMgr" failed to start: 2
fixme:service:scmdatabase_autostart_services Auto-start service L"PlugPlay" failed to start: 2
Fontconfig warning: “/etc/fonts/conf.d/50-user.conf”, line 9: reading configurations from ~/.fonts.conf is deprecated.
fixme:actctx:parse_depend_manifests Could not find dependent assembly L"Microsoft.Windows.Common-Controls" (6.0.0.0)
p11-kit: couldn’t load module: /usr/lib/i386-linux-gnu/pkcs11/gnome-keyring-pkcs11.so: /usr/lib/i386-linux-gnu/pkcs11/gnome-keyring-pkcs11.so: cannot open shared object file: No such file or directory
err:winediag:SECUR32_initNTLMSP ntlm_auth was not found or is outdated. Make sure that ntlm_auth >= 3.0.25 is in your path. Usually, you can find it in the winbind package of your distribution.
fixme:heap:HeapSetInformation (nil) 1 (nil) 0
fixme:ole:CoInitializeSecurity ((nil),-1,(nil),(nil),0,3,(nil),0,(nil)) - stub!
fixme:heap:HeapSetInformation (nil) 1 (nil) 0
fixme:process:SetProcessShutdownParameters (00000100, 00000000): partial stub.
fixme:resource:GetGuiResources (0xffffffff,0): stub
fixme:win:EnumDisplayDevicesW ((null),0,0x32dc60,0x00000000), stub!
fixme:win:EnumDisplayDevicesW (L"\\.\DISPLAY1",0,0x32d918,0x00000000), stub!
fixme:win:EnumDisplayDevicesW ((null),1,0x32dc60,0x00000000), stub!
fixme:winhttp:WinHttpDetectAutoProxyConfigUrl discovery via DHCP not supported
fixme:msg:ChangeWindowMessageFilter 233 00000001
fixme:msg:ChangeWindowMessageFilter 4a 00000001
fixme:msg:ChangeWindowMessageFilter 407 00000001
fixme:msg:ChangeWindowMessageFilter 49 00000001
fixme:bitmap:CreateBitmapIndirect planes = 0
fixme:bitmap:CreateBitmapIndirect planes = 0
fixme:wtsapi:WTSRegisterSessionNotification Stub 0x1005a 0x00000000
err:ole:marshal_object couldn’t get IPSFactory buffer for interface {00000131-0000-0000-c000-000000000046}
err:ole:marshal_object couldn’t get IPSFactory buffer for interface {00000122-0000-0000-c000-000000000046}
err:ole:StdMarshalImpl_MarshalInterface Failed to create ifstub, hres=0x80040155
err:ole:CoMarshalInterface Failed to marshal the interface {00000122-0000-0000-c000-000000000046}, 80040155
fixme:msg:ChangeWindowMessageFilter c04f 00000001
fixme:richedit:ME_HandleMessage EM_SETFONTSIZE: stub
fixme:dbghelp:elf_search_auxv can’t find symbol in module
wine: Unhandled page fault on read access to 0xffffffff at address 0xf7591c5a (thread 0009), starting debugger…
err:seh:start_debugger Couldn’t start debugger (“winedbg --auto 8 5552”) (2)
Read the Wine Developers Guide on how to set up winedbg or another debugger

Hi
Am getting exactly the same error, has anyone managed to fix this yet?
Thanks

shameless bumb… same problem here Teamviewer simply refuses to load

I guess its an error within the wine version and 64bit related only ?
So you might fix it with installing the 32bit version of libp11-kit-gnome-keyring:.

So from a commandline execute the following:

sudo apt-get install libp11-kit-gnome-keyring:i386

Hi leszek

Thanks for the suggestion but that did not work either…

I have this problem with 32bit system.

I tried 32bit and 64bit Teamviewer debs on clean installs of 64bit Netrunner, and I have the same problem, Teamviewer freezes and fizzles out right after the license agreement.

When I run into ksysguard I can see the teamviewer process being a zombi one, and the wine process stuck and then dying by itself.

From the command line I get the same garbage as previous users on this thread.

So my question is: has anybody succeeded in running Teamviewer on Netrunner, or is this otherwise awesome distro doomed as a professional system because of it’s lack of support for a primary application used by dozens of millions people around the planet ?

Why is every distro broken some way or the other ? There is ALWAYS something wrong, that you realize at the last moment generally…

I’m really sad because I fell in love with Netrunner the first minute I booted it, but I need Teamviewer for my work and will have to go back to something else if no solution is to be found.

I tested that again on a newly installed Netrunner 13.06 (64-Bit) with the teamviewer 64bit deb from the official site and don’t seem to have any problem regarding installing or running teamviewer.

The same goes for running it after an uptodate Netrunner system.

So I guess it might be also a hardware limitation of some way.
Please post your graphicscard and if you are using an nvidia or ati/amd one do you have the proprietary drivers installed ?

Hi,

I have an AMD Radeon HD 6970M with fglrx-updates installed.

I will try in a virtual machine to see if I can reproduce the bug.

Thanks for caring about us and I will let you know if I find a solution.

Hi Leszek

Can’t be hardware for me as it runs perfectly under Kubuntu 13.04 - will downgrade nvidia drivers and try again - kubuntu running stock - no nvidia yet

Zeb…

OK no matter what drivers I use for my graphics card it simply does not work. it maybe something to do with Wine so I will try updating that… will report back

I had no wine installed in my tries. Maybe it has todo something with a parallel installed wine.

ok brand new install of Netrunner - no updates run yet. Ran 64 deb installer… installs… runs… no interaction possible with the Team Viewer screen that pops up. Try to close it and a pop up tells you you have to close the wine process to do so.

System Activity says zombie for teamviewer process

Linux i5-zeb-netrunner 3.8.0-23-generic #34-Ubuntu SMP Wed May 29 20:22:58 UTC 2013 x86_64 x86_64 x86_64 GNU/Linux
MemTotal: 6023276 kB
MemFree: 2484876 kB
Buffers: 581616 kB
Cached: 1988468 kB
SwapCached: 0 kB
product: GK107 [GeForce GT 640]
vendor: NVIDIA Corporation
description: CPU
product: Intel® Core™ i5-2320 CPU @ 3.00GHz
configuration: driver=nouveau latency=0

Teamviewer works perfectly well on kubuntu and SolydXK

It would be a real shame to have to consider dropping Netrunner…