Unable to boot when using LVM

When installing Netrunner using LVM, upon a reboot, I get the following error message:

ERROR: device 'UUID=......' not found. Skipping FSCK'
ERROR: Unable to find root device 'UUID=......'
You are being dropped to the recovery shell
Type 'exit' to try and continue booting
sh: can't access tty: job control turned off'

I’m installing it in VMWare Workstation 10.0.3 on Windows. Most articles on Google say this is a problem on a kernel update, but this is a fresh install. And the closest solution I’ve found is http://superuser.com/questions/769047/unable-to-find-root-device-on-a-fresh-archlinux-install/788480#788480 but I can’t even boot into the fallback image to do it. And using the live dvd and chroot results in mkinitcpio complaining that proc is not mounted.

You can mount /proc and /sys in chroot with

mount -t proc proc proc
mount -t sysfs sys sys

But it needs /dev also mount binded from the live system.

sudo mount -o bind /dev /path/to/mounted/chroot

As for the general problem is there any log file of the thus installer that might help debugging the problem?

Well, I’ve tried installing it a few times, and every time the install seems to succeed properly. If there’s a location where I can grab the install log, let me know and I’ll post the log here.

Sorry forget that. Logs are stored at /var/log

Here’s the install log.

EDIT: I’ve attempted to try the solution at the link I posted earlier, but no dice.

The first issue I ran into was mkinitcpio complaining abt a missing /boot/vmlinuz-314-x86_64 which I solved by copying over to the root partition’s /boot from the boot partition. It successfully generated the initramfs and initramfs-fallback, which i copied over to the boot partition.

However, on a reboot, the problem still shows up. So now, I’m officially completely stuck.

Also, I should note that this only happens when I use LVM, it works perfectly normally without LVM.

I redownloaded the new ISO, checked the md5, installed into a brand new VM, and still no dice.

Don’t ask me why, but did you enable 3D support in the VMWare Workstation settings?
You’ll also need to make sure that open-vm-tools, open-vm-tools-dkms and xf86-video-vmware are installed on the VMWare Image, these are not usually installed by default.

Yes, I did enable 3D support, otherwise I wouldn’t have been able to boot into the live session at all.

Also, how would I check those packages are installed? I can’t quite boot into anything beyond a very limited recovery shell, or a live dvd, at the moment.

I’m pretty sure the issue is related to LVM somehow, since the exact same installation without LVM works, and boots perfectly fine.

The open-vm-tools-dkms package has the vmware kernel drivers. These may be required to use LVM, I’m not sure but it’s worth a shot.

open-vm-tools-dkms conflicts with linux314-open-vm-tools-modules, which also has the kernel modules.

I’m getting the same error on two machines one an Acer M1610 with a Core2duo and the other an i3 CPU (specs not to hand). I’ve tried installing with LVM and without but still get the same bash error on start up.

Netrunner Frontier looks impressive running as a Live CD, and if I can get this Distro working I’m intending to switch all my PC’s over to it. It’s very slick. A sweet job.

I know the installer supports LVM, that’s where I installed it, but does the kernel need to be recompiled with lvm support, or should it be there already?

I’m getting ‘unable to find root device’ at start up and ‘blkid’ doesn’t show any lvm partitions from the emergency shell that it drops into.

Note that I’m doing a weird install because there are other OS on this machine, I’m not looking for help getting it running - I broke it, I’ll fix it - I just want to know that the problem isn’t with the kernel and that therefore I’m wasting my time trying to fix it.

I looked in mkinitcpio.conf and lvm2 is there, so it seems to me that it should be in the kernel but I’d like to be sure.


It is already in the kernel, but what your describing is prior to the kernel booting, you may need to restore grub:

That’s interesting, just before the error I can see vmlinuz bring expanded, thought that was the kernel? Grub seems to be working for the other OS that are also in lvm so I assumed it was OK for Netrunner. I’ll check grub.cfg again, to make sure the lvm module is being loaded correctly.

Yes, but which one of your Linux installs has control of grub, and does it understand your LVM layout with regards to Manjaro? When you have more than one distribution of Linux installed working with grub 2 can get complicated.

It didn’t initially, but I thought I’d fixed that; grub-mkconfig said it had found and configured it, doesn’t work though.
I’m going to reinstall and give the grub partition to Netrunner, see if it works then. Assuming so I’ll then try and add the existing distros. I’ll back up the grub partition first, so I can compare later.
The lvm setup isn’t complicated, it’s just one lv per OS, so I can take snapshots before upgrading and the like, /home is on raid and there’s one real boot/grub partition. It seemed like such a good idea when I first thought of it!

Hmmph, so I did the full install, including grub, and it still fails with the same error. On the plus side, it did find all my other OS so it’s only Netrunner that doesn’t boot.
The emergency shell is definitely Linux, not grub, so the kernel is loaded but I can’t see any lvm partitions from it. Also lsmod doesn’t list lvm, but then I don’t know if it should.
I’m going to rebuild the kernel, I know lvm is in mkinitcpio.conf so it should build it with lvm support, if that fixes it I’ll know for sure.

The kernel is built with LVM support, that can’t be the problem.

What is the make and model of your raid controller?

You could always post your issues on the Manjaro forums as well:

Weird then, because rebuilding the kernel with lvm support has fixed it, it now boots.

It doesn’t start though, because there’s a problem with the fglrx module. /var/log has ~500 xorg.log files, all the same, they end with:

[ 30.155] (EE) fglrx(0): atiddxDriScreenInit failed. Probably kernel module missing or incompatible. [ 30.155] (WW) fglrx(0): *********************************************************** [ 30.155] (WW) fglrx(0): * DRI initialization failed * [ 30.155] (WW) fglrx(0): * kernel module (fglrx.ko) may be missing or incompatible * [ 30.155] (WW) fglrx(0): * 2D and 3D acceleration disabled * [ 30.155] (WW) fglrx(0): ***********************************************************

Ho hum…
Ok it seems that fglrx was built for xorg 1.49 but I have xorg 1.5 (something like that - can’t see the logs right now).
II assume that I caused this by rebuilding the kernel, but I can’t resolve it because I can’t even get a cli login prompt.

Is there a grub option to tell it to not start X?

So, this is how I fixed it from the live disk:

[code]$ su

mkdir /mnt/arch #optional, you may also just use /mnt/

mount /dev/sdax /mnt/arch #substitute sdax with your root partition (or maybe /dev/mapper/vgname-lvname)

mount /dev/sday /mnt/arch/boot #only needed if you have a seperate partition sday for /boot

mount -t proc proc /mnt/arch/proc #mount system folders

mount -t sysfs sys /mnt/arch/sys

mount -o bind /dev /mnt/arch/dev

chroot /mnt/arch/[/code]

You then need to edit /etc/mkinitcpio.conf, on the line with ‘HOOKS’ add ‘lvm2’ just before ‘filesystems’, like so:
HOOKS=“base udev autodetect modconf block keyboard keymap plymouth lvm2 filesystems fsck”


[code]# mkinitcpio -p linux314


umount --recursive /mnt/arch[/code]

Then reboot, hopefully all will be well.