[Update] 2014-12-01 - Manjaro 0.8.11

For this release Manjaro focused on bringing more attention to the common core requirements of Manjaro’s broad user-base. Over five weeks have passed since the last update making this is a very large update (300+ Packages).

This update can be run using Octopi only if the bash update was applied prior, otherwise use the the command line will be required:

sudo rm -R /var/lib/pacman/local/bash-4.3.024-1
sudo pacman -Syy
sudo pacman -S bash pacman manjaro-system
sudo pacman -Su

Here is the official release announcements:
https://forum.manjaro.org/index.php?topic=18313.0;topicseen

After this upgrade I cannot restart or even shutdown from the menu.

I have no sound icon and I cannot control the volume of recorded material. Some other icons work fine, like terminal or time, language of keyboard.

Sould I try to upgrade again? Maybe using terminal and not octopi?

Had no probs the last two upgrades and really a problem now when I cannot power the os down.

Can you shutdown/reboot after upgrade with the terminal? sudo reboot
Does it work after reboot?

Sometime when a running kernel gets a version bump, there are a few minor issues like the ones your having, these are normally solved by a reboot.

Which volume icon isn’t working, kmix or veromix?

If you mean veromix, I can tell you that kdeplasma-applets-veromix-git Version 23.cac3925-1 from the blueshell repository doesn’t work after this update, you’ll need to uninstall that version and enable the kmix volume control icon in the system tray properties.

However if you really like veromix better, than you have a few optional versions you can install:

  1. kdeplasma-applets-veromix-git-blueshell
    Version 4.53c5233-1 from the Blueshell repository.

  2. kdeplasma-applets-veromix
    Version 0.18.3-7 from the AUR.

  3. kdeplasma-applets-veromix-git
    Version 29.183dcbd-1 from the AUR.

  4. veromix-git (GTK & KDE included)
    Version 2.4eeab4c-1 from the AUR.

Thank you Leszek, I could reboot from the terminal.

I got my sound icon again and so to test I selected restart from the menu and my system rebooted. After logging on with my password I got no sound icon and the restart from menu does not work, again.

I got this message
KDE session manager
error launching /home/trevor/kde4/ autostart/preload.desktop
either KLauncher is not running anymore or it failed to start application

How do I power down from the terminal, please? Then I can try again tomorrow.

You can use sudo poweroff to shutdown in the terminal. For the preload script inautostart see the firefox-kde thread. In short the new update breaks it. So I recommend disabling this script in systemsettings -> startup and shutdown

Hi Leszek and AJ,

I appreciate the time you give to help at what must be a busy post upgrade period.

I installed a sound icon from categories in add widget from panel options. It works.

I disabled both KLauncher and Preloader in system settings, rebooted from terminal and still the restart and shutdown options in the application launcher or menu do not work. However, suspend in the launcher does work.

So, I can control my os from the terminal but still not from the application launcher.

Are you sure the update ran smooth to the end. Can you try triggering it again to see if it maybe pulls in or configures some stuff.

Yes, it works with all the stuff enabled at start up and sound and octopi icons in the panel. I used the terminal to update and despite reporting nothing to do after the last command AJ said we should use, my system works except for Firefox. Will wait for the foxy update.

Thanks again

This is something i had , too check this post Volume doesn’t launch.

It is a “bug” that affects many, just google kde shutdown/logoff doesn’t work. From what i had searched at that time kde fails to fully load. For other was changing backend to phonon-vlc, for others systemd permissions.
In my case since sddm was upgraded ( after this upgrade plymouth for me also works ,it was enabled but didn’t work before) and moved on to 3.17 kernel it hasn’t happened again.

Netrunner by default ships with the veromix volume control widget enabled by default, this is NOT a standard Plasma widget. The problem is that with a rolling system like this one the applications need to be upgraded at the same time as their dependencies, this is what happened in the case of the missing icon, which I explained in my previous post.

Yep, had the same issue with TrevorK. The Kmix would not start and could not reboot/shutdown from the kicker.

Did now disable the preload script in System settings/autostart and it seems to have worked, didn’t get the error message and kmix launched.

However I did not have a script called Klauncher in the autostart menu? Should everyone have that? There was a script called krunner but I assume that is not what you guys meant…

There is only the preload script. This script like every on autostart gets executed by klauncher. So there should not be a klauncher script.

I think a new live image is due as this is a rather huge update

This latest update-pack was huge because it was 5 weeks worth of updates, as I said before this is not the norm, the update-packs are usually released between 2-3 weeks apart, unless there are major bugs, breakages and/or compatibility issues that need more attention. However, this does not mean that if a critical security issue is discovered that it won’t be patched and pushed out sooner, for example we had two bash updates during this time.

Thanks, makes sense.

However, even after inactivating the preload script again Kmix didn’t load now when I started my laptop. How can I make Veromix the default?

As I understood it changed some time ago to be the default in Netrunner however that didn’t seem to have happened to my install when I upgraded. I can right click and add it to the system tray, however many times when Kmix has not launched and I add veromix, next time Kmix might launch and then I have two of the sound icons. Nothing major, just a minor annoyance…

Open up System Tray Settings and put a check next to Veromix, then change Volume Control to “Hidden” under Entries.

However, make sure you don’t have kdeplasma-applets-veromix-git from the blue shell repository installed, trying to use that version can cause the issues your both describing.

Well upgraded and had some errors not sure about?

[code]linux314-3.14.25…
error: failed retrieving file ‘linux314-3.14.25-1-x86_64.pkg.tar.xz’ from mirror.jmu.edu
: Operation too slow. Less than 1 bytes/sec transferred the last 10 seconds
linux316-3.16.7.1-1…
linux316-3.16.7…
error: failed retrieving file ‘linux316-3.16.7.1-1-x86_64.pkg.tar.xz’ from mirror.jmu.edu
: Operation too slow. Less than 1 bytes/sec transferred the last 10 seconds

harfbuzz-icu-0.9.36…
error: failed retrieving file ‘harfbuzz-icu-0.9.36-1-x86_64.pkg.tar.xz’ from mirror.jmu.edu
: Operation too slow. Less than 1 bytes/sec transferred the last 10 seconds

kdepim-runtime-4…
error: failed retrieving file ‘kdepim-runtime-4.14.3-1-x86_64.pkg.tar.xz’ from mirror.jmu.edu
: Operation too slow. Less than 1 bytes/sec transferred the last 10 seconds
kdebase-workspace-4…

kdebase-workspac…
error: failed retrieving file ‘kdebase-workspace-4.11.14-1-x86_64.pkg.tar.xz’ from mirror.jmu.edu
: Operation too slow. Less than 1 bytes/sec transferred the last 10 seconds
kdebase-plasma-4.14…

lib32-libdbus-1.8.10-1 lib32-libgpg-error-1.17-1
libgpg-error-1.17-1 libgphoto2-2.5.5.1-1 libgpod-0.8.3-3

upgrading ca-certificates-mozilla
error: command failed to execute correctly
upgrading python2-cherrypy

warning: directory permissions differ on /var/cache/cups/
filesystem: 775 package: 770

upgrading libgpg-error
upgrading lib32-libgpg-error

Found linux image: /boot/vmlinuz-316-x86_64
Found initrd image: /boot/initramfs-316-x86_64.img
Found initrd fallback image: /boot/initramfs-316-x86_64-fallback.img
Found linux image: /boot/vmlinuz-314-x86_64
Found initrd image: /boot/initramfs-314-x86_64.img
Found initrd fallback image: /boot/initramfs-314-x86_64-fallback.img
/dev/cdrom: open failed: No medium found
/dev/sde: open failed: No medium found
/dev/sdf: open failed: No medium found
/dev/sdg: open failed: No medium found
/dev/sdh: open failed: No medium found
/dev/sdi: open failed: No medium found
No volume groups found
Found Windows Vista (loader) on /dev/sda1
Found memtest86+ image: /boot/memtest86+/memtest.bin
done[/code]

Maybe no biggies here? Mostly just scripts or mirrors that aren’t there or haven’t been removed and should be?
As they catch us newbies eyes as possible problems and don’t know how to proceed with them.

Only thing to figure out is if I’m using SDDM or older KDM. Because my auto-logon isn’t working on bootup. And forgot if I switched to SDDM which I think I’m using and doesn’t seem to work with auto-logon. And still no themes showing in SDDM system settings and wondering why it’s the default?

Thanks for any assistance or help as always appreciated.

.

The first issue looks to be a server timeout.
You can use rankmirrors to update your server list and to organize them according to speed:
https://wiki.manjaro.org/index.php/Rankmirrors_to_Set_the_Fastest_Download_Server

sudo pacman-mirrors -i -c all sudo pacman-mirrors -g

SDDM is under heavy development, an the current version is 0.11.0, here is the change-log:
https://github.com/sddm/sddm/blob/master/ChangeLog

Since the new version of SDDM doesn’t need the /etc/sddm.conf file any longer the update renames the existing file to /etc/sddm.conf.pacsave. You can however put the file back to restore your settings like this:

sudo mv /etc/sddm.conf.pacsave /etc/sddm.conf

Hi Guys,

Two days after the second loading of the latest rolling update, I have the same issues with the application launcher and task bar.

I cannot shutdown or restart using buttons or menu in the app launcher. Also some applications do not launch, like unetbootin but others like libre office do. I can launch from the terminal, fine.

I cannot minimise windows of running applications since they do not appear in the task bar. Also, octopi alert icon is missing again from the task bar and on powering up the icons in the task bar are in completely different positions.

I can use my system, but it is getting a little inconvenient and the fun, ease of use and speed has disappeared with this upgrade.

Any input would be gratefully received.