[Update] 2015-01-04

Manjaro 0.8.11 Update pack 4 now online:

There should be no Issues with this update, however since there was a grub2 / osprober update as well as the Intel graphics drivers please reboot once the update is completed.

You can update as usual with octopi or from the command line:

sudo pacman -Syu

For more information please read the Official Manjaro Announcement here:
http://manjaro.github.io/Update-2015-01-04_(stable)/

Or the Official Announcement forum thread here:
https://forum.manjaro.org/index.php?topic=19314.0;topicseen

Thanks voted there updated thru Octopi zero issues after re-booting.
Tho still seem to get the retrieval package error for the ftp: japan mirror. Think I’ll start commenting out mirrors that are consistently failing to retrieve packages. Usually same ones on every update.
.

Or you could just use sudo pacman-mirrors -i to make a custom mirror list or any of its other arguments:

[quote]-h, --help show this help message and exit
-g, --generate generate new mirrorlist
-m {rank,random}, --method {rank,random} use generation method
-b {stable,testing,unstable}, --branch {stable,testing,unstable} use branch name
-c COUNTRY, --country COUNTRY use only mirrors from country[,country,…]
-d MIRROR_DIR, --mirror_dir MIRROR_DIR use path as mirrorlist directory
-o OUTPUT, --output OUTPUT specify output file
-t TIMEOUT, --timeout TIMEOUT server maximum waiting time (seconds)
-i, --interactive interactively generate a custom mirrorlist
-v, --version print the pacman-mirrors version
[/quote]

This link is just in case you ever just want to check the status of the Manjaro mirrors: http://repo.manjaro.org/

Thanks for the info and your help.
.

Just to inform, there’s an issue with the new intel driver, probably Sandybridge processors using Bumblebee. Still need collecting more info on this.
https://forum.manjaro.org/index.php?topic=19345.0

Which bumblebee combination are you running nvidia/Intel or the nouveau/Intel?

I just tested Google Chrome as well as Opera and Chromium with pepper flash installed and they are not doing this, it only seems to be a Firefox, chromium, etc. using the patch but outdated Flash player plugin having this issue.
I will be contacting the Firefox and youtube developers about this, I will keep you posted when I find out something.

PS. The Firefox developer asked me if you have proper VDPAU and the libva drivers installed installed?


libvdpau + lib32-libvdpau - Nvidia VDPAU library
mesa-vdpau + lib32-mesa-vdpau - Mesa VDPAU drivers
libvdpau-va-gl - VDPAU driver with OpenGL/VAAPI backend


libva - Video Acceleration (VA) API for Linux
libva-intel-driver - VA-API implementation for Intel G45 and HD Graphics family
libva-mesa-driver - VA-API implementation for gallium
libva-vdpau-driver - VDPAU backend for VA API


One of my replies in the update topic::
https://forum.manjaro.org/index.php?topic=19314.msg175613#msg175613

Are you sure it’s a flash/firefox issue, because it’s like my complete DE is affected by it, using the new intel driver.

I have three laptops with the sandy bridge Ivy bridge and haswell chipsets, I haven’t noticed anything as far as the DE having issues.

Are you sure your not loading up in plasma workspace failsafe mode?

Yes I saw that post and it’s the reason I asked the first question, it seems like this isn’t effecting the nouveau/Intel bumblebee combination, unless I missed something.

Seems to me that I remember something about the nvidia driver now having primus support under Linux. wouldn’t that mean that they would have issues with bumblebee?

I don’t use bumblebee so I’m not sure.

I’ve autologin enabled, is there any quick way to check if I’m in failsafe or not? Because my desktop looks always normal to me, with autostarts like conky and plasmoids.

interesting!

What you asked before:
The Firefox developer asked me if you have proper VDPAU and the libva drivers installed installed?


libvdpau: installed v0.8-1
lib32-libvdpau: not installed
Nvidia VDPAU library

mesa-vdpau: not installed
lib32-mesa-vdpau: not installed
Mesa VDPAU drivers

libvdpau-va-gl: not installed
VDPAU driver with OpenGL/VAAPI backend


libva: installed v1.5.0-1
Video Acceleration (VA) API for Linux

libva-intel-driver: not installed
VA-API implementation for Intel G45 and HD Graphics family

libva-mesa-driver: not installed
VA-API implementation for gallium

libva-vdpau-driver: not installed
VDPAU backend for VA API


It would look normal however it would be using the CPU for rendering instead of your GPU.

To check if your in failsafe mode, logout and look in the left hand corner of SDDM, it should be listed as Plasma workspace and not Plasma Workspace (Failsafe Mode) if it’s the latter change it and log back in.

You’ll need to install the other two VDPAU as well as libva-vdpau-driver for your nvidia chip to have accelerated video playback in games, etc.

Now as far as libva and your intel chip:
If you have a G45 or later you’ll need to install the libva-intel-driver
otherwise if you have an earlier GPU then install the libva-mesa-driver

When I log out it doesn’t show the Plasma workspace listing, maybe I’m on another theme. But can’t change the theme through system settings, looks like that’s broken, and don’t know which is default theme.
My /etc/sddm.conf
https://www.zerobin.net/?991256e140b214f2#HskZq0u+7qxY3IgRsF2qdXUAEmR8/EKni2zWVVfpsr8=

Ok, so I installed, and it didn’t brake the system :wink:

Installed libva-intel-driver (1.5.0-1)
Installed libva-vdpau-driver (0.7.4-2)
Installed lib32-libvdpau (0.8-1)

Yes, we already know about the kcm-sddm for KDE 4 being discontinued and replaced with sddm-kcm which only works under KF5.

According to the sddm.conf you posted it looks like your using the Maui theme which is the default and should have the drop down window in the left hand corner for session type.

However you shouldn’t even have a /etc/sddm.conf file anymore, the SDDM package version 0.10.0 no longer requires it and should have deleted it, you should only have a sddm.conf.pacnew and a sddm.conf.pacsave, unless it was kept due to the autologin settings.

Ok I removed that one to the recycle bin, and now I see I’m using the Plasma Desktop.
I noticed, when I edit a few entries in the sddm @ systemsettings, a new sddm.conf is created with the changings.

Yea, I know it partially works, :slight_smile:

The thing is that SDDM changed the way it works and where it stores some of it’s configuration files.

For a quick reference on some of the changes you can have a look at it’s change log: https://github.com/sddm/sddm/blob/master/ChangeLog

Basically SDDM now runs as it’s own user and uses a pam.d file for autologin as you can see here:
[attachment=559]