[Update] 2015-02-14

Manjaro 0.8.12 update-pack 1 now online:

This is a very large update today which includes KDE SC 4.14.5 and KDE Applications 14.12.2.

Other updates include:
Mesa - 10.4.4 (now supports DirectX 9)
NetworkManager - 1.0
Firefox/Firefox-kde - 35.0.1
Plasma 5 - 5.2

Security updates to several packages including chromium.
And as always regular Arch Linux upstream fixes included as of Feb 9 2015.

All supported kernels
3.10.68, 3.12.37, 3.13.11.15, 3.14.32, 3.16.7.5, 3.18.6 and 3.19.0
with BFQ-Scheduler updated to v7r7.

Note: 3.17-series is EOL and will be removed from our repositories soon.

Some of the KDE applications version 14.12.2 have been ported to frameworks and will need you to answer yes to remove the non KF5 versions to complete the update.
Because of this the terminal option in Octopi or manual update will be required:

sudo pacman -Syyu

Take your time and make sure to answer Y (yes) at all the prompts.
A reboot will be required with the new Kernel updates.

Note: If your experiencing longer boot times this is because systemd has removed readahead, but fear not there are stand alone versions in the AUR:

For Standard HD’s

yaourt -S systemd-readahead

and for SSD’s:

yaourt -S systemd-sreadahead

Official Manjaro announcement: https://manjaro.github.io/Update-2015-02-14_(stable)
Official Manjaro forum feedback post and poll: https://forum.manjaro.org/index.php?topic=20478.0

Upgrade and reboot went to OK as far as I can tell.

During upgrade I got this:

[code]resolving dependencies…
:: There are 2 providers available for phonon-qt5-backend:
:: Repository extra

  1. phonon-qt5-gstreamer 2) phonon-qt5-vlc

Enter a number (default=1): [/code]

I just entered default of 1. Sound stuff is working OK.

Cheers

Yes, that’s the recommended back-end for phonon, your good.
Did you install systemd-readahead as well?

Not at first. before installed I did some baseline boot times, then I installed readahead
I did do the important notes:
[size=x-small][quote]Important: for it to work you need to enable the systemd services like this:

systemctl enable systemd-readahead-collect
systemctl enable systemd-readahead-replay
[/quote][/size]

Here are the results (in seconds)

Grub to KDE Login KDE Login to KDE Desktop total before readahead... Test 1 31 39 70 Test 2 32 40 72 after readahead... Test 3 51 50 101 Test 4 30 39 69 Test 5 27 32 59 Test 6 35 27 62

After the first couple of reboots, looks like it will save about 10 secs.

Just wondering - Plasma 5 is mentioned in the release info, does this mean that it is considered stable enough to use instead of 4x ?

Yes, however you would need to remove all of the Netrunner Rolling specific blueshell repository packages as well as Most of KDE SC 4 to get it to install.

There are also still quite a few base applications like dolphin and konquerer that are still being ported to KF5 and not available yet. So just like the current Kubuntu test ISO’s, you’d end up with more of a hodgepodge of Plasma 5 and KDE SC 4 than a complete DE on it’s own.

However, Anex over at Manjaro has put together a great ISO that uses a special repository he set up that includes updated KF5 libs, new KF5 builds of key applications like Dolphin, etc. and the new kdepim (Akonadi PIM) suite with kmail2, blogilo, etc. and much more.
Personally, especially since there is no easy upgrade path from KDE SC 4 to Plasma 5, I’d play with that on a test system first rather than possibly destroying your install of Netrunner Rolling.

Tried to do a sudo pacman -Syyu
Hit return defaults for all and got the

[quote]:: kactivities-frameworks and kactivities4 are in conflict. Remove kactivities4? [y/N]
error: unresolvable package conflicts detected
error: failed to prepare transaction (conflicting dependencies)
:: kactivities-frameworks and kactivities4 are in conflict[/quote]

As had issue trying to update using Octopi and it ends up in terminal mode also due to package conflicts?
How is it 90% seem to be issue free upgrades for other users. And I seem to always get these kind of update issues?
As default install with open drivers so no proprietary drivers issues and such.

And always getting Replace prompts as don’t have a clue to give a Y or N so don’t know why my upgrade should stop due to them.

[quote]:: Starting full system upgrade…
:: Replace kdebase-katepart with extra/katepart4? [Y/n]
:: Replace kdebase-konsole with extra/konsole? [Y/n]
:: Replace kdegraphics-gwenview with extra/gwenview? [Y/n]
:: Replace kdesdk-kate with extra/kate? [Y/n]
:: Replace libreoffice-still-common with extra/libreoffice-still? [Y/n]
:: Replace libreoffice-still-en-US with extra/libreoffice-still? [Y/n][/quote]

Also weird after editing this post. I was logged out and had to manually log back into forums.
.

You don’t want to just do the default:

[quote]…will need you to answer yes to remove the non KF5 versions to complete the update.
… make sure to answer Y (yes) at all the prompts.[/quote]

Thanks for the heads up. As I don’t know what I have to answer Y or N. And seems kind of confusing to have defaults that are mixed like that. I imagine there are others like me that don’t the Why’s of overriding the defaults. So leads to confusion and doubt and fear of borking our setup.

.

I had the same problem yesterday, but after e-mailing Clemens, he sent me a response as to the reason why.
This is because netrunners URL changed, you just need to edit your shortcut link from http://forums.netrunner-os.com/ to http://forums.netrunner.com/.

[hr]

I’m not sure why that happens either, especially since the update won’t complete if you go with the default of n. I will ask one of the pacman developers I know as to why this happens and get back to you.
[hr]
Update: Well as it turns out there are many reasons for this issue, sometimes the dependency string in a package could be formatted wrong, another package being updated could depend on this replacement process but hasn’t been updated yet (timing issue), etc.

Thanks for the info and yep things like these makes it hard for casual user that doesn’t want to learn to set the timing or adjust the carburetor under the hoods kinds of things. And seems to be no way for the user to determine if it’s a installed package on his end. Or something the user did. Or something wonky on the sending ends. Makes for frustration at times.

.

My rule of thumb is if I trust the source, Hit Y if not hit N.
That functionality is only there to protect users from malicious packages being installed on earlier releases of ARCH, prior to use of pgp signing of the packages, and now from servers that use the SigLevel = Never line in the pacman.conf file.

Update went fine, for the most part. My only issue is with the KDE packages replaced by extra repository packages: konsole, kwrite, kate, gwenview.

I’m not sure what’s the cause, but window style is different and font rendering looks noticeably worse in these applications (see attached screenshot) (also, I think there’s an increase in memory footprint, but I can’t be sure).

Is there a way to at least make the style and font rendering consistent with the rest of KDE? Or are these KDE5 packages now?

Um, this has already been discussed and solved in this very thread.
Read first, post second would be the best advice I have to give right about now.

Second there is NO such thing as a KDE 5, those are KF5 based (KDE Frameworks 5) packages not Plasma 5 packages. Plasma 5 is the DE, KF5 is the libraries and API’s etc. used by Plasma 5, KDE applications and soon some parts of LXQt now that they are very modular as well.

The difference is this:
KDE SC 4 is/was a Software Compilation which had only one release cycle that includded Plasma 4, kdelibs 4 and API’s as well as the included applications.

Now these are all separate projects with thier own release schedules:
KF5 (KDE Frameworks 5) - contains the libraries, API’s, and other components made to extend QT5.

Plasma 5 - Workspace, compositor and desktop components (aka Desktop Environment)

KDE Applications - the included applications that used to ship with plasma 4 and Kdeibs 4 (KDE SC 4)

https://techbase.kde.org/Schedules

Apologies, I have read the thread, but I don’t see a solution to my problem, all I see is an explanation.

As you note, in order to proceed with the update, I had to give the (non-default) ‘Y’, so these packages got replaced. The problem I report is with the new versions. So, unless I am missing something, where is a solution given in this thread, apart from (possibly) downgrading said packages?

Oops, your right it’s not in this thread it’s in this one: http://forums.netrunner.com/showthread.php?tid=17282

I do sincerely apologize for this.