[Update] 2015-06-12

Major base system update to Manjaro 0.8.13.

This update should be relatively issue free.
You can use octopi or the command line to perform this update:

sudo pacman -Syyu

Included in this update are fixes to some KDE Applications 15.04.2 like dolphin and konquerer, etc.

This update-pack also includes all regular Archlinux upstream fixes as of June 06, 2015.

Official Manjaro forum thread: https://forum.manjaro.org/index.php?topic=23446.0

:: Starting full system upgrade…
resolving dependencies…
looking for conflicting packages…
error: unresolvable package conflicts detected
error: failed to prepare transaction (conflicting dependencies)
:: kinfocenter and kdebase-workspace are in conflict

received the error above.

Yes, kinfocenter is not compatible with KDE SC 4 any longer and only available as part of the Plasma 5 desktop environment. You’ll need to remove it before updating your Plasma 4 desktop.

I’m using Plasma 5 though. Thanks for the quick reply.

Well then, it would seem that something else went wrong when you performed the upgrade from KDE SC 4 to Plasma 5. kdebase-workspace is part of KDE SC 4 and should have been replaced with plasma-workspace when you transitioned to Plasma 5.

Did you use my tutorial to perforn the transition to Plasma 5, or did you use some other method?
http://forums.netrunner.com/showthread.php?tid=17392

Yes, I followed that instructions and did not have any issues with any steps. Any other ideas as to why i’m receiving that error?

No not really, If you are indeed running Plasma 5 then kdebase-workspace would conflict with 90% plus of the Plasma 5 /KDE frameworks 5 / kdeapplications 15.04.2 packages installed on your system.

Also this line ion the tutorial would have removed kdebase-workspace from your system:
sudo pacman -R kdebase-workspace