[Update] 2015-06-29

Manjaro 0.8.13 update-pack 2.

Included with this update:

Linux 4.1.0 LTS kernel has been added to the repositories
Steam client received various fixes
Octopi 0.7.0 received some much needed patches
SystemD updated to 221

As always this update includes also regular Archlinux upstream fixes as of Jun 28 2015.

Current supported kernels
[]Linux310 3.10.81
]Linux312 3.12.44
]Linux314 3.14.45
]Linux318 3.18.15
]Linux40 4.0.6
[*]Linux41 4.1.0

You can use octopi or the command line to perform this update:

sudo pacman -Syyu

Official Manjaro announcement: https://manjaro.github.io/Update-2015-06-29_(stable)/
Official Manjaro forum thread: https://forum.manjaro.org/index.php?topic=23921.0

Not sure what the cause, but after the update vlc causes a total freeze of the system with most videos. I have tried changing the preferences, and even resetting them, but I can’t seem to be able to fix this. Essentially, I have no video. :frowning:

Checking the log, I see there was no update to vlc (I have version 2.2.1-6), but I had an update of xf86-video-intel (2.99.917-5 -> 1:2.99.917+364+gb24e758-1).

I have an intel HD graphics card.

Any ideas?

Okay, I tried mpv also, and I can confirm that the problem is due to hardware acceleration, since the freeze occurs when I try to enable it, but I don’t know how to fix it.

You may need to Install the libva-intel-driver package for proper video hardware acceleration.

sudo pacman -S libva-intel-driver

libva-intel-driver is already installed, but I’m not sure if I have it properly configured.

If I disable hardware accelaration and use xv video driver in vlc, I get comparably watchable video, but the CPU load suffers.

I had problems with a previous mesa update, which I haven’t yet solved, and I had to disable hardware acceleration in firefox and chromium to get them to stop lagging. It may be that my graphics card is too old and is slowly becoming obsolete.

That could be, I have a core 2 duo here that I have to set the compositor in Plasma 5 to xrender or everything is horribly laggy, even just opening the menu takes about 20 sec with opengl enabled.

Would a mesa downgrade be worth the trouble? Video is workable now, but I’m beginning to fear new updates.

Seems that the latest xorg / mesa drivers for Intel are autodetecting opengl 3.2 on all thier GPU’s, even old ones like on my core2duo. Try going into system settings and changing the compositor to whatever your GPU can handle. I’ve also discovered that on Intel GPU’s at least, that setting the tearing prevention (vsync) to full screen repaints fixes many GPU related issues on KDE4 / Plasma5.

My current settings are:

Compositing type: OpenGL 2.0
Qt graphics system: Raster

Tearing Prevention (VSync): Full scene repaints

I’ve tried many different settings before, and settled on these because of different issues (lag in desktop effects, high CPU load). I’m hesitating to fiddle right now, since I have a workaround, but I’ll give it a try when I have time.

For tear free video try adding this option to /etc/X11/mhwd.d/intel.conf:

Section "Device"
   Identifier  "Intel Graphics"
   Driver      "intel"
   Option      "TearFree"    "true"

If that doesn’t help you could also try using UXA instead of SNA.

Reference: https://wiki.archlinux.org/index.php/Intel_graphics

Manjaro 0.8.13 update-pack 3 seems to have fixed my video issues.

In VLC, I have hardware accelerated video with the settings:

Video --> Output: Automatic
Input/Codecs --> VA-API video decoder via X11

Next time could you please post in the right thread for the update-pack your referring to?
In this case update-pack 3: http://forums.netrunner.com/showthread.php?tid=17840

All right. I posted here because the previous update pack caused the issue, and the discussion was in this thread, but I will keep it in mind for the future.

The fix probably came with the update to VLC 2.2.1-6.
This being based on Arch/Manjaro there is very little patching other than what comes out of the upstream projects.