Update fails, nvidia conflict

Hi,

I cannot update my system. pacman -Syu gives me error: failed to prepare transaction (could not satisfy dependencies)
:: linux315-nvidia: requires nvidia-utils=343.22

pacman -S nvidia-utils gives me error: failed to prepare transaction (could not satisfy dependencies)
:: linux315-nvidia: requires nvidia-utils=343.22
:: linux317-nvidia: requires nvidia-utils=343.22

Thanks for your time.

is this is your first update since you installed your system?
If so, did you do the bash update as the readme file on the desktop suggests?

No, I’ve been using Netrunner for a few months. At the time, I did do the bash update, as advised. I think bash is up to date, version bash-4.3.030-1. My last update was a week or two ago.

OK, have to ask, as most people don’t read instructions, I’m also just trying to get a felling for where your system is at chronologically speaking.

When was your last update done (IE. which update-pack point)?

pacman.log shows the most recent update: [2014-11-02 14:08] [PACMAN] Running ‘pacman -Syu’
That update completed without errors etc.

OK then, do you have both of those kernel series installed?

To keep up with the updates, you might wan’t to install octopi-notifier, or at least keep an eye on the Netrunner Rolling sub-forum as I post the update-pack announcements as they come out.

There have been TWO update-pack releases since that big one, Manjaro usually releases update-packs every two to three weeks, unless something major delays them longer. They also occasionally release security updates in the interim between update-packs.

I’m not sure I understand your question. According to Manjaro Settings Manager, I have 3.17.4-1 and 3.15.10-1 installed, running 3.17.4-1. What else do I need to check?

Netrunner rolling allows you to have more than one kernel installed at a time.
So it’s a yes then,

First things first though, there have actually been three update-packs and two security updates since 2014-11-02.

Here is what you need to do first:

sudo pacman -Syy sudo packman -S pacman manjaro-system sudo pacman -Su

I’ve done all of that and still get the same error.

OK then, unless the 3.17 kernel has issues or you need the 3.15 kernel as a backup, you can either remove the 3.15 kernel:

 sudo mwhd-kernel -r linux315

or you can force the installation of the nvidia-utils package (not recommended):

sudo pacman -S nvidia-utils --force

then repeat these commands again:

sudo pacman -Syy sudo packman -S pacman manjaro-system sudo pacman -Su
[hr]
I just noticed errors in my post, i have corrected it now.

mwhd-kernel -r linux315 gives me bash: mwhd-kernel: command not found

[root@Netrunner jim]# pacman -S nvidia-utils --force
resolving dependencies…
looking for inter-conflicts…
error: failed to prepare transaction (could not satisfy dependencies)
:: linux315-nvidia: requires nvidia-utils=343.22
:: linux317-nvidia: requires nvidia-utils=343.22

Oops, typo its mhwd-kernel not mwhd-kernel. However, you could also just use the Manajro System Settings > Kernel GUI to remove the 3.15 kernel. :slight_smile:

sudo mhwd-kernel -r linux315

If you didn’t decide to remove the older kernel then in that case, the pacman -S nvidia-utils --force command I gave you ended up with the force flag in the wrong place, and since it is a bad Idea to use the force flag anyway, let’s just tell pacman to ignore the dependencies when installing that package:

sudo pacman -Sdd nvidia-utils

Ok, we’re making progress. I used the Manjaro Settings Manager to rmove the older kernel and then ran the commands you specified and everything seems to have worked as expected. Thank you very much for your assistance. Also, your timeliness and patience with this, thanks again!

You might want to run sudo pacman -Syu at least once more just to be sure you got all of the updates installed, especially the security oriented ones.

Anyway, that’s what I am here for there is no need to thank me, and may you have a marry Christmas or what holiday you celebrate.