Very Slow graphics performance

Hi there,

I’ve just installed rolling couple of days ago, coming from Ubuntu 14.04 and since I have separate home partition I adjusted the mount point during installation. my problem is after installation and update the graphics performance is very slow I mean I the response is very slow for example when I play some video on the screen with VLC and try to skip a couple of minutes ahead the video stop completely. even switching between apps are very slow
My hardware is a dell notebook N5110 i7 quand core with 8 Gigs of RAM intel/Nvidia 2MB graphic card

mhwd -li

Installed PCI configs:


              NAME               VERSION          FREEDRIVER           TYPE

video-hybrid-intel-nvidia-bumblebee 2014.10.03 false PCI

Warning: No installed USB configs!

can somebody help me please.

thanks in advance.

This might be the problem, with 2MB, you won’t get anywhere :stuck_out_tongue:

No really,
There’s a performance issue with the new intel-driver (.917) for some of us, you might need to downgrade to the previous version and add it to the IgnorePkg list into your /etc/pacman.conf.

downgrade to the earlier version:

sudo pacman -U /var/cache/pacman/pkg/xf86-video-intel-2.99.916-3-x86_64.pkg.tar.xz

some info: https://wiki.archlinux.org/index.php/Downgrading_Packages#How_to_downgrade_a_package

Adding to the ignorelist in /etc/pacman.conf

IgnorePkg   = xf86-video-intel

We have to wait until it gets fixed.

Thank you very much for your response, unfortunately I only have xf86-video-intel-2.99.912-2-x86_64.pkg.tar.xz and xf86-video-intel-2.99.917-1-x86_64.pkg.tar.xz
in the path you mentioned from where can I download the motioned package?

for the time being I switched to free drivers and it seems to solve the problem but CPU fan is going crazy.

thanks

You can download it from
http://seblu.net/a/arm/packages/x/xf86-video-intel/xf86-video-intel-2.99.916-3-x86_64.pkg.tar.xz NOT recommended!
source: https://wiki.archlinux.org/index.php/Arch_Rollback_Machine

do a md5sum checksum and verify

500a28bc1b89af6052ced12cb8a823f7

after that place it in your /var/cache/pacman/pkg/ folder, and do the downgrade

Thank you very much for your help. I really appreciate it.

Never install drivers from a non trusted source, or anywhere else besides the official Manjaro repositories.
Netrunner Rolling is based on Manjaro, Manjaro is not Arch compatible. Manjaro uses their own repositories, build their own kernels and their graphics stack is also different, do NOT use any packages from the Arch repositories especially drivers.

What you need to do first is make sure that your system is completely up-to-date.
This includes the bash shell security updates described in the read me:

sudo pacman -Syy
sudo rm -R /var/lib/pacman/local/bash-4.3.024-1
sudo pacman -S manjaro-system pacman
sudo pacman -Su

reboot

Next you’ll want to update your system to a newer kernel that has the latest patches for your Intel hardware.
You can do this via the Manjaro Settings Manger > Kernel or from the command line:

sudo mhwd-kernel -i linux318 rmc

reboot again.

My next question would be, do you wish continue using the Nvidia proprietary drivers or would you rather use the nouveau opensource drivers for you Nvidia chip with bumblebee?
Keep in mind that the Nvidia chip will only be used for applications when specifically told to using optirun / primusrun.
https://wiki.manjaro.org/index.php?title=Manjaro_Hardware_Detection
https://wiki.manjaro.org/index.php/Configure_Graphics_Cards
https://wiki.manjaro.org/index.php?title=Configure_NVIDIA_(non-free)_settings_and_load_them_on_Startup

I understand your concern, but ofcourse I compared the checksums of the one in the download with the one of the Manjaro repo in my pacman cache, both are exactly the same. So I presumed they were identical and not harmfull.

But I’ll take your advice. :blush:

Do you know the place were we can find the older packages of Manjaro and/or Netrunner?

If it was installed on your system during an update and not from the ISO then the older version should be in your local pacman DB cache, this is of course provided it hasn’t been cleared out since.

/var/cache/pacman/pkg/

No, Manjaro keeps it’s xorg config files in a different place than Arch due to MHWD.

/etc/X11/mhwd.d/

Well thank you very much AJSlye for your response,
I had installed xf86-video-intel-2.99.912-2-x86_64.pkg.tar.xz using downgrade and it seems have worked fine.
answering your question well I don’t mind using either nouveau or Nvidia but the problem is that nouveau turn the fan like hell not sure why.
I had already upgraded the system but I have not updated the kernel I’m currently using 3.14.28-1 do you recommend upgrading to 3.18?

Manjaro has fixed the early microcode loading in grub for ALL supported kernels now in the last update-pack, so you should be fine. However with newer kernels usually comes better performance, and bug fixes, so I would have to say YES, but I also always recommend keeping at least one working LTS kernel installed to be safe, it’s ultimately up to you.

Well I had tried, I did upgrade the driver then the Kernel but the performance went slow again.
So I had to downgrade the driver as suggest by flipper and the system is ok now

thanks a lot for your support

Please keep in mind that by using the xorg Intel package from the Arch repository you may no longer be able to use the mhwd command to configure graphics drivers. These driver keep their config files in a different place than Manjaro does due to the fact that Arch does not use MHWD (Manjaro Hardware Detection).

Thank you very much AJSlye for your concern, but unfortunately I don’t have any other option the performance of
xf86-video-intel-2.99.917-1-x86_64.pkg.tar.xz is unacceptable ant I feel it cripple the system and the fan is always on when I use the nouveau
so I hope the next version of the driver that may resolve the issue.

thanks a lot for your support and concern

Not a problem friend, that is what I’m here for.

If you have any other issues or if somewhere down the line you do have any trouble stemming from that driver package, just know that I will be here to help. :slight_smile:

I really appreciate all the help and I’m really pleased by the level of support you guys are providing.

thanks a lot

After recent updates, can you try to upgrade to version 2.99.917-1
It should work.