Virt-Manager and Kwallet


I’ve been struggling for some time now with Virt-manager and Kwallet.

when I try to connect to an hypervisor here’s the error I get:

It doesn’t even ask me for a password.

I tried to recreat a new wallet, didn’t change anything. Of course, libvirtd is running on my hypervisor.

When I kill all kwallet process and try to connect, it ask for the kwallet password, I say no and then I get the ksshaskpass window and can finally connect to my hypervisor.

But then kwallet is kind of broken for my browser and such …

Has anyone seen something similar ?

One think I’ve seen when killing kwallet is that there’s 2 of them, kwalletd and kwalletd5.

Maybe Virt-Manager is trying to use the deprecated kwalletd instead of the plasma 5 version ?


It sounds to me like this. So it should work nevertheless.
Not sure whats wrong here though. I never worked with libvirtd

Ok, I have two ideas:

  • Using ssh keys on my hypervisor.

  • Setting manually the password in kwallet

I got a question about that, does the kwallet management GUI apply changes to both versions ?

Or do I need to add password entries using kwalletcli ?

If none of those work I’ll try to look further …


You need to set it up for both as they are not syncing as they are used for different applications