Why is everything so SLOW??

Especially Firefox… but really… everything is very slow to respond.
I wonder if it is video related?

I tried unchecking BLUR under Desktop Appearance, no change.

Tried adding a DreamScene video desktop and it is choppy.

HP Slimline Pavillion - 2.66 Intel processor, 128gig Crucial SS HDD, 4 gigs memory.

Which graphics driver is in use ? (Check under My Computer)

Display Info
Vendor: Mesa DRI Intel® G33
2D driver: intel
3D driver: Unknown classic (10.1.3)

Also, when I go onto the YouTube site, it takes a minute or more for everything to load!
This did not happen in 13.12 .

Man that’s an old chip-set, defiantly turn off composting.

Yah, but I thought that was suppose to be one of the good things about Linux…
You can run anything as it’s not supposed to be a resource hog. But I guess
that’s changing. Catching up to Winblows.

Edit: Can you instruct me on HOW to shut it off?

KDE has always been heavy compared to the others, gnome has actually caught up in this regard. go into system Settings > workspace behavior > Desktop Effects and click the advanced tab, make sure your Composting type is not set to opengl 2.0, also be sure that the QT graphics subsystem is set to native not raster. To turn desktop compositing off on the general tab of Desktop Effects remove the check for Enable desktop effects at startup, then hit alt+shift+f12…