Yaourt not working in Octopi

I have just installed 2015.11, and everything is working great on it apart from a strange issue with Octopi. When I use the Yaourt option, it searches the AUR fine, for example breeze-icons-extras, but it does not install it.

It says ‘running command in terminal’ and then ‘Command finished OK!’. The terminal does not appear and the root authentication dialog does not appear. I have checked and xterm is installed, does it need anything else?

Is anyone else having this problem? How do I fix this?

The command line works fine, so I know Yaourt is working fine and installs software without any problems. Does octopi have a separate log file I can investigate?

I ran octopi from the command line, but did not see any error messages.

Please help.

Make sure you still have kdesu installed, and that you have rebooted the system after your last update.

Yes I have got kdesu installed and have rebooted several times. The only modification I made was to remove akonadi as it was using a lot of RAM. Still the same problem.

Strange, it’s working fine here.
When you ran the latest updates, did you use the command line, Octopi, or Muon Updater?

I used muon updater. I think best thing is to wipe it and start again. If I figure out what caused it, I will let you know.

Muon had quite a few bug fixes since the ISO was released, and may not have updated all of the installed packages.
Before you try a reinstall, make sure you received ALL the updates by using the pacman from the terminal.
Use the following command to ensure that the local DB is up to date, and that any packages that may have been downgraded upstream are also downgraded on your installation:

sudo pacman -Syyuu

Unfortunately, that made no difference, only glibmm was downgraded after running the command you suggested. I will wipe this and start again, I have only built it two days ago, so not much will be lost.

I will let you know what happens with the new version.

Thanks for your help, it is appreciated.

I tried it again. I did a clean install, and updated using pacman. Rebooted. Tried installing from Yaourt and the same thing happened. So very puzzled indeed.

I tried Manjaro as well and that is working, so I will wait for the next version of netrunner rolling and see what happens with it. Since Manjaro is fine, I can use that instead.

It is a strange problem.

Further update, it has started working. I do not know how, but the Konsole is now showing. I will investigate further, and see if I can tell why it has started working. No need to use my Manjaro build after all.

Found out what I did to make it work. After rebooting, the first time I install from aur using octopi, the Konsole does not appear. However, if I the select it again and press install it then works and I see the Konsole window.

So it seems to be the first time after a reboot.

Does this provide anyone with any clues about why this is happening. It is not happening in Manjaro, as I have just tested that and it works every time.

Found the solution, which is to set the terminal to Konsole in the octopi config file. I found the answer here:


Hope this helps if anyone else finds this problem.

The other option is to use pamac which is working perfectly.