13.12 live usb boot issues [solved]

hi guys, i am having an issue with getting 13.12 (32 and 64 bit) running via live usb. i have tried multiple usb boot installers such as lili and unetbootin, multiple pc’s and multiple flash drives and it still refuses to load up, below are the busybox commands that it brings up as it attempts to load.

(initramfs) done.
calling test-builtin
error reading /lib/udev/hwdb.bin no such file or directory
load module index
unload module index
[a few lines which are identical to above]
mount: mounting /dev/loop0 on //filesystem.squashfs failed: no such device
can not mount /dev/loop0 (/cdrom/casper/filesystem.squashfs) on //filesystem.squashfs

this issue is not present on dvd’s of 13.12 or 13.06 version

Did you check the md5sum of the ISO? It seems that either it can’t find filesystem.squashfs file or can’t load the loop module for the kernel.

thanks for the reply, i verified the md5sums and they match, filesystem.squashfs exists within the .iso also

Hmm maybe the usb stick isn’t detected. But you tried it with many different ones on many different machines right ?

indeed, its a confusing issue, 13.12 works fine via DVD but 13.06 has zero issues via my flash drives and unetbootin

issue resolved, i used a program called “universal USB installer” with a 2GB persistence file and it works perfectly via usb now, no boot issues. but lili and unetbootin still give me issues

mitchy93: indeed weird, i use unetbootin for 13.12 and works over here…

I experienced that sometimes the default boot entry isn’t working with unetbootin. However the OS specific entry most of the times work.

Hello, My distro does not come with universal usb installer. But i tried dd, it did not quite work in either case, for both manjaro and debian versions (64 bit)

What was your dd command you used ? What did not work ? Did it just not boot or didn’t come up with the boot manager when you choose boot from usb ?

sudo dd if=Downloads/netrunner-13.12-dvd-64bit.iso of=/dev/sdb1

From my home directory, 25 GB ext2 primary partition (the first partition) on a 32 gb drive.

The bios can not seem to find an OS there.

Thats the problem the command is wrong.
You don’t want to write the iso to one partition but to the whole stick. This means use /dev/sdb as target when your usb stck is located there.

Many thanks. I will do it now.

Also, to add for it, I tried unetbootin from chakra, it failed for both 64 bit debian and 64 bit arch kernels. The I tried unetbootin from OpenSuse, same, then finally i tried unetbootin from Kanotix, which worked with the Arch kernel.