Back to Netrunner | Back to Blue Systems

13.12 wireless stops working when waking from sleep

I recently upgraded my laptop to 13.12, using the upgrade script. When powering up, my wireless card (a Broadcom BCM 4312) works fine, auto logs into my preferred networks, etc. However, when waking from sleep, wireless networking doesn’t work. There isn’t even an entry for wireless networking in the Network Management widget in the system tray.

I have the exact same problem since upgrading. My HP Pavilion g7 has a Ralink wireless card. And a continuing bug from the last several months is the screen brightness is turned to zero every reboot, and I have to manually bump it up in order to see the log in screen.

Ron

It might be a kernel issue. Perhaps it makes sense to boot into the older kernel from 13.06 release to see if it happens with it also. (to make sure it isn’t a firmware issue)

I’ll give it a shot. A workaround I use for now is to open system monitor, kill networking manager, and then it will automatically restart and connection is made.

Ron

Ah so it is not a driver issue but a network-manager issue. Does deactivating the network manager instead of killing and reactivating work too ?

How would you recommend I do that? I didn’t see that as an option.

(Update): Sent an INT signal from system monitor and did the same thing.

Ron

I have a similar problem, but installed a “new” system , and the wifi card intel 3945abg

Does the fix “restarting network manager” help for you ?

no,
#stop network-manager
service networking stop

Remove and reload the module for the wifi card

modprobe -r -f iwl3945
modprobe iwl3945

Start networking and network-manager again

service networking start
start network-manager

  • not work

Is there a solution for this problem already? Running Netrunner 13.12 64bits.

Not really. I upgraded my firmware from the latest debian experimental which helps not to get that so often but it still happens and network-manager disabling and after a few minutes enabling it always worked for me (at least when it isn’t a router issue itself)