14.2 update broke dolphin

I open a new thread to explain my last installation starting from Netrunner 14.2
Installation from a DVD, with separated partitions for / and /home.
The first step run perfectly. After boot i had a stable system which only lacks the french translation files.
I updated the mirrors with muon-updater. I only added the language pack useful for french.
At this level all is OK. The machine is actually running in this configuration.
If i perform an update of packages always unsing muon, all seems to run as expected.
But at the first boot, Dolphin became unusable.
To understand what happens see the 2 png file before and after update.

Any ideas ?
Each time you open a session of Dolphin you add a new serie of places in the left panel.

Many thanks for the suggestions

I checked the same sequence on a laptop. First installation of 14.2 ans then update. This time all is OK. No bugs with dolphin.
The previous machine has a SSD disk, but it was running Netrunner 14.2 perfectly until the last update.

Has anyone an idea of workaround for this problem. The SSD machine is the daily desktop of my wife.

Many thanks for your suggestions


seems something like this happened before with “old” dolphin4 running under “kde5”:

So a newer update of packages could now have triggered something similar for users still using kde4 and therefore dolphin4, see package list that worked as described mentioned here: https://bugs.kde.org/show_bug.cgi?id=347246#c14


What versions do you have installed?

I do not dare to update the machine but :
before update :
kdelibs-bin 4.14.2
kio-audiocd 4.14.2
dolphin 4.14.2

What i can add is that under the laptop i submitted to the same installation (netrunner14.2) and the update i found :
kdelis-bin 4.14.13a
kio-audiocd 4.14.3
dolphin 4.14.3a

I never found any kdelibs-4.14.8.

Many thanks

Do you think i can do a partial update for kernel ?


After the last update I had kde “freezing” (I had to shutdown the machine with sudo shutdown from tty1 because no other commands were available). It seems that the problem is generated by starting dolphin from the icons of dolphin folders I had in a panel I added. I removed the panel and I have no more problems with dolphin (by the way my PC has an SSD too). I never had the problem you described and from the images you posted you do not seem to have added a panel with folders icons so after the last update dolphin is having multiple problems.

A new occurrence of dolphin bug (filing of places panel), after last update on a machine of a friend of mine.
I will have access to the machine tomorrow afternoon.
It seems that a package in update may be responsible of this dolphin bug although not systematic.


Some update i had to do (on the SSD desktop):
First : flashplayer to allow video playing on some sites
Second : libkexiv2-11 from 4.14.2 to 4.14.3 for digikam.
These two, were update using Synaptic and no dependences were asked for.
At that stage the dolphin bug did not appeared.


If i want to repare this machine by formating the / and leaving /home intact should i erase the ~/.kde/share/apps/kfileplaces/bookmarks.html on each user home ?
Is this useful ?
many thanks for any suggestions.


Yeah removing it would definitely help to see if it’s really a bug in dolphin or just a strange error of files or linking on your system.

So i checked two new machines of my friends.
The two exhibit the dolphin bug. The last one, i updated it 2 hours ago through muon. Screen copies are demonstrative.
For the two i deleted the .kde/share/apps/kfileplaces/bookmarks.html
This did not resolved the problem. Further this action did not clear the place list. After reboot the place continue to fill in at each dolphin session.
Where is that list ?

Any idea ?
It seems to be a real bug of dolphin not so unsual.


If its not the bookmarks.xml file then it might be ~/.local/share/user-places.xbel file. Please check it and make sure it isn’t a symlink.

So first it is a solid link. Then removing user-places.xbel and reboot no changes, filing goes on.
Removing both all .xbel files and all boomarks.html and reboot, samething.
The place list increase at each dolphin session.


What about this discussion :

Did you tried that proposed workaround there and does it work for you?

The problem for me is that i do not understand which entries are they talking in a file such as :

<?xml version='1.0' encoding='UTF-8'?> Dossier de projet kdenlive

between which tags i delete the data, there is really few things ?

I have perhaps found a workaround of the bug.
I observed that my desktop, which did not exhibit the bug, has already a favorite within the panel;
I chose to erase this favorite (right click on it). then dolphin started to duplicate home, root, network, trash.
Each session of dolphin added a new series.
Then I decided to add a new favorite on the panel, and i deleted the previous duplicate (right click option).
As expected now the duplicate of entries did not occur.

I suspected that machines which did not exhibit that bug have already favorites on the panel or at least the file indexer (baloo) activated.

Confirmation, adding a favorite folder on the panel, prevent the duplicate of all home, root, network and trash links at each session of dolphin.
The post can be considered as solved, but probably the bug of dolphin still deserve attention.

Leszek many thanks for the exchanges.


Thanks for figuring out that bug.
I hope it can be useful to others and a fix can be found upstream aswell :slight_smile: