14 Frontier Update

Grrrr… a bit of failure here… Had to reinstall Muon, System Settings, I lost veromix tray applet and could not to restore it. Swapped the .kde directory in hope it will restore Netrunner’s defaults. But what I got was crappy KDE defaults (why my META key does not bring the start menu?! Where’s my cool lower panel?!). Could someone tell me how to get the Netrunner default desktop restored ??

Also I got this:

$ sudo apt-get update

W: Failed to fetch http://ppa.launchpad.net/netrunner-os/frontier-14-packages/ubuntu/dists/frontier-14/main/binary-amd64/Packages 404 Not Found W: Failed to fetch http://ppa.launchpad.net/netrunner-os/frontier-14-packages/ubuntu/dists/frontier-14/main/binary-i386/Packages 404 Not Found E: Some index files failed to download. They have been ignored, or old ones used instead.
I managed to tackle this as said he: http://forums.netrunner-os.com/showthread.php?tid=17088&pid=25291#pid25291

No chance I will do a fresh installations of 14.1 - too much customisation, too much python packages to install, MATLAB and stuff…


when did you do this update?
Was it on 24th or before?

Before 24.01.2015 - pretty much when it showed up. But I was discovering different little flaws for the next couple of days and Iim trying to fix’em one-by-one. The lack of Muon was an easy one.
How I can restore default desktop - or I am lacking some packages to do that? netrunner-default-settings are here and a new user, when created, gets the Netrunner’s look and feel.

I have tried:

mv ~/.kde ~/.kde.old
sudo reboot

But that brings the default look of KDE (but with Netrunner’s menu icon and Kicker) and Netrunner’s custom start-up scripts are missing too. Did KDE 4.14.2 change the place where the default live on the system?

You can copy the defaults from /etc/skel/.kde
As for the systemsettings and veromix make sure to have netrunner-systemsettings-settings and the plasma-scriptengine-python packages installed.
It should be usable with your old .kde directory aswell.

OK, so I did Alt+Ctrl+F2 and

killall plasma-desktop sudo cp -r /etc/skel/.kde /home/theUser/ sudo reboot
And it seems to work with this message popping out here and then:

Configuration file "/home/theUser/.kde/share/config/kaccessrc" not writable.
Please contact your system administrator.

It is assigned to root, so one have to change the group and permission:

sudo chown -R theUser: /home/theUser/.kde/share/config