2014.04 new installation won't update

I reformatted my main computer, and installed the Netrunner Rolling 2014.04. When I tried to update the system according to the “read me” notes I get the following error messge, when I’m at the third command line “sudo pacman -Suu”. I answered all the questions to Y, and at the end I get the following error message.
Failed to prepare transaction (conflicting dependencies)
: : mhwd and mhwd-dev are in conflict

I was able to install the Rolling version on my test laptop, and was able to update with no problem. Then I installed on my main desktop, and was able to update the very first time with no problem, but couldn’t get the Virtualbox to work properly, specifically activating the USB on Windows 7 in the Virtualbox. So I decided to give it another try, since I’m a little more familiar with the Rolling version, but now it won’t update. I even burned another iso, and checked the md5sum, and everything is correct. I don’t know at this point if I should wait for the 2014.08 Rolling to come out or switch back to the Frontier? Any solution to this as to why it’s not updating?

You don’t need mhwd-dev, I would remove it. Let me know if there are any other issues. There will be a new ISO very soon as well.

Hi AJ,

That worked. I think everything is updated now, because I don’t see any message for any updates. I was also was able to install the Virtualbox through Otopi, and only had to downlad the Extension pack from Oracle in order for the USB to work inside the Virtualbox. The only minor issue that I’m noticing is that when I launch Octopi, it takes a long time for it to launch, and it won’t do it all the time. So I don’t know if I should be concern about that? So do I have everything that would be in the 2014.08 version? Also how do I check for any new updates?

Yes, other than Plymouth is now fixed to run at boot (like it’s supposed to), and the Account Details freezing issue has also been solved, you are up to date software wise. There are a few new wallpapers, etc. but these can eventually be updated via packages in the blueshell repository. Now as far as octopi taking a long time to load, this has to do with it reading the contents of the pacman cache directory.

Nice one :smiley:

To have octopi notify you of new updates automatically you will need to install octopi-notifier: sudo pacman -S octopi-notifier

I have a two part question.

I did the sudo pacman -S octopi-notifier, and the new update that you posted today. Should you check the forums on a regular basis and keep up with all the updates with the Rolling version? After all, pacman didn’t notify me about that update that you posted today.

Back to your post #4, What is the Plymouth that is not fixed yet?

octopi-notifier will sit in the system tray and notify you of updates when they are available, usually about every 2 weeks.

When you install using the current media. Plymouth does not start at boot, the new ISO’s coming out does, it’s just a fix in the installer.

If you wish to fix Plymouth on an already installed system then follow the instructions in this thread:

So was this update a permanent fix? In other words would I be better off with the new ISO, or do we gain anything extra with the new ISO when it’s out? Is Plymouth that you’re talking about is a kind of ISO update?

Please, re-read my post, there is a link to the forum post about how to fix the Plymouth bug on an already installed system.

There are new ISO’s coming soon, however, there is nothing on the ISO that is new for an already installed and updated system. There we’re a few bugs that we’re fixed in the installer but these bugs and the fixes for them have already been discussed and the solutions posted in the forums.