AceStream not working

Has anyone got AceStream working on Rolling?

Installed the player and engine both from the AUR:

yaourt -S acestream-player

When I click on an AceStream PlayNow link, it opens a new blank tab on Firefox and shortly after ACE player HD (VLC) opens but nothing happens after that. If I copy the stream URL it won’t let me paste it in AceStream player?

Thanks for any help.

Edit ACE player preferences and for demuxer module put it in FFmpeg demuxer.

Thanks, tried that but has made no difference. Anything else I could try?

First thing to do is make sure you have the optional dependencies installed for the types of streams your trying to open:

I installed acestream and it worked fine, but I’m running Chrome and not Firefox.

Did you install this package: acestream-mozilla-plugin

$ yaourt -S acestream-mozilla-plugin


Yes I had already installed acestream-mozilla-plugin. Just tried in Chromium and it says it needs to launch an External Protocol Request xdg-ope. When I click Launch Application nothing happens again.

I’m just trying to view streams from Wiziwig such as


Did you make sure the plugin is enabled in Firefox?

You might also possibly need to disable or remove from loading on start up, I’ve found this can sometimes cause issues with certain plugins.

I found this for you as well:

[quote]You’re probably going to want to add a handler for your browser, so that when you click an AceStream link, it will be opened up in the AceStream player.

To do this click on any AceStream link in your browser, and when the Launch Application dialog displays, click to choose an application. Next, navigate to /usr/bin/ and select acestreamplayer. Click Open and your stream should start playing in the external AceStream player. You can also choose to have the browser remember this, so that in future, all acestream:// links launch directly in the player when clicked.[/quote]


Thanks for the help, have tried all your suggestions, still no luck. Even tried on my brother’s computer, not working there either!

I have the same problem. Did you find a solution?

I said I used chrome not chromium, Firefox and chromium currently do NOT support DRM content under Linux. This may be why you cant get the player to work. Google Chrome and the new version of Opera are the only web browsers currently supporting DRM content under Linux.

No, I always get an error message in Chrome:

Cannot connect to engine. Check if engine installed.

The engine is installed.

The engine is marked out of date at the moment.
You can read the comments in the AUR here: