AMD Graphics Driver

When I choose the fglrx or the fglrx-updates options it turns back to the free driver despite running as root ,


thanks in advance ,

Had the same problem. Use this guide:

Instead of installing the Linux headers which seem to already be installed, update them with sudo apt-get update. If while generating the fresh xorg config it tells you your hardware is unsupported, go back into the the driver manager and change the driver from fglrx to fglrx updates. Then reboot.

What AMD card do you have, some of the AMD drivers and Nvidia drivers, went to legacy drivers for older cards.
It sounds, lke it’s telling you, it won’t work, but I could be wrong.
My son is a Linux Sys Admin and likes AMD, but uses Nvidia in his machines, because he says there are a lot of issues with fglrx. His family PC has a AMD card, relativley new, but he runs the open source driver and it works great.
How new or old, is the card?

A possible way to test compatibility. I run an AMD Radeon 3000 series in my present laptop. I previously had Xubuntu installed, with FGLRX drivers. I tried installing KWIN as the window manager. No go. Every time I set the WM to KWIN, I logged into a frozen system. I’m guessing there was a conflict between the FGLRX drivers and KWIN (which is a known issue). I then installed Netrunner on the same system with OPENGL, and everything works.

If you have a spare partition to play around with, try installing something like Xubuntu, then KWIN as the WM. See what happens?

KWIn has 3 different OpenGL options and one Xrender option if you really need a composite desktop. Otherwise it should work fine without compositing on AMD cards aswell.