android mtp help [SOLVED]

Hello All,

So i have 2 computers with netrunner on them, one has 13.12 and the other which is my main pc has 14.
The one with 13.12 i am able to connect to my android tablets storage (mtp) but on the pc with 14 i can’t, I can only connect to the camera (ptp)

in lusb it detects my device but it wont let me view my storage.

I have a tegra note 7 running android 4.4.2

any help would be great, thank you.

Make sure you have kio-mtp installed.

Just a thought, why not just use KDE Connect?

thank you for the reply

i do have kio-mtp insatlled but still it wont work.

I’m not really sure what to do about it anymore since my phone (android 4.4.2) will connect but my tablet android 4.4.2) wont, it’s very weird.

kde connect seems pretty cool. I have that installed now but i have one question, how do you send files to the tablet from dolphin? if i could figure that out this might be perfect.

thank you again.

That does seem weird. What is your tablets make & model?

KDE Connect needs to be installed and running on both devices and then paired together.

About KDE Connect: https://community.kde.org/KDEConnect

The following link is from above site.

“How to integrate Android into KDE Linux desktop”
http://xmodulo.com/2014/01/integrate-android-kde-linux-desktop.html

Here is the link to KDE Connect in the Play Store:
https://play.google.com/store/apps/details?id=org.kde.kdeconnect_tp&hl=en

For the latest news on KDE & KDE Connect here is Albert’s blog:
http://albertvaka.wordpress.com/

I have a EVGA TEGRA NOTE 7 Tablet running Android 4.2.2

I guess i will have to wait for the official release of kde connect 7.2 for dolphin intergration, i hope not long because i’m loving kde connect and the ability to transfer files from my file manager would be great.

http://albertvaka.wordpress.com/2014/06/28/awesome-contributions-to-kde-connect/

Agreed, however transferring files is already integrated into 0.7.2, you’ll just need to wait for Netrunner 14 (Ubuntu/Debian) / Kubuntu 14.04 LTS to catch up.

Since I’m running Netrunner Rolling I’m already using KDE 4.13.3 & KDE Connect 0.7.2-1 and I’ve got to tell you the Dolphin integration does work great, you’ll absolutely LOVE it.

If you have mtp-tools package installed you could run mtp-detect to see if the tablet is recognized by libmtp if it is listed as unknown this is the issue why kio-mtp isn’t showing you the device.
Just as stated in the command output from above you then must contact the libmtp developers and tell them the two ids of your tablet.

After some searching I may have found the solution to your MTP issue.

Open Konsole and type: sudo kate /etc/fuse.conf
Next change #user_allow_other to read user_allow_other and save the file.
You should now be able to use your tablet with MTP.

Reference: http://ubuntuforums.org/showthread.php?t=2226702&page=2

edit:
As far as KDE Connect you could try the Kubuntu back ports PPA:
https://launchpad.net/~kubuntu-ppa/+archive/ubuntu/backports
or the Kubuntu Updates PPA:
https://launchpad.net/~kubuntu-ppa/+archive/ubuntu/ppa

I tried your suggestion AJSlye but still nothing.

So i tried what leszek said iand i got

"unable to open ~/.mtpz-data for reading, MTPZ disabled.libmtp version: 1.1.6

Listing raw device(s)
Device 0 (VID=0955 and PID=cf00) is UNKNOWN.
Please report this VID/PID and the device model to the libmtp development team"

so i will report that soon, but i decided to do a google search on why i got this.
“unable to open ~/.mtpz-data for reading, MTPZ disabled.libmtp version: 1.1.6”

and a few people said to plug the device into a usb3 port (forgot i even had one) so i did, and tegra7 popped up in dolphin but it didnt show anything in the folders.

also thanks for the backports and updates links AJSlye, i might give one of those a sht.

and thank you for replying both of you.

The mtpz error is normal. Mtpz is a obsolete yet still supported by libmtp plugin for Microsofts Zune Media Player

thats good to know thank you.

so after a while i decided to plug my tablet in again and voila it’s connected and i was able to move files on to it.

I find it very odd that i needed to plug it into a usb 3 o=port to get it to work, but oh well it does.

again thank you guys for your help. this is solved.