Back to Netrunner | Back to Blue Systems

Are there even any bugs in NRR ?

The only minor inconvenience I found in NRR was the “memory test” GRUB entry, which does not like to be moved around in the GRUB-customizer (–> error), so just leave it where it is.

Other than that it is the best ARCH I am aware of.

Grub Customizer, and similar utilities like grub2-editor-frameworks are problematic for most Arch based distributions, especially Manjaro which NRR is based on. This has to do with the way Manjaro loads the Intel microcode by default, and why all of these utilities are not in the main Arch or Manjaro repositories, but only available from the AUR.
https://wiki.archlinux.org/index.php/microcode#GRUB
https://wiki.archlinux.org/index.php/GRUB/Tips_and_tricks#GUI_configuration_tools

because of the /@… file business, NRR grub is not recognized by , say, Debian 9.

One needs to manually copy entries into the relevant grub.cfg to be able to boot NRR again after debian installation (onto the same hard disk).

This is why I provided the links that I did. :wink:

NRR (like Manjaro and Arch with intel-ucode installed) must be used to manage grub or you loose the ability to boot into it.
Most other distributions (like Debian, Ubuntu, etc.) do not know how to handle the way grub loads the intel-ucode under Arch/Manjaro.

{note: :idea: put in wiki here }
[hr]

On a NRR btrfs install, one runs into:

grub error: sparse file is not allowed - press any key to continue

good news: even without keypress, booting will resume
bad news: this cannot be fixed easily

[hr]
links:
https://bugs.launchpad.net/ubuntu/+source/grub2/+bug/736743
http://lists.gnu.org/archive/html/grub-devel/2011-02/msg00011.html
https://btrfs.wiki.kernel.org/index.php/Compression
https://www.spinics.net/lists/linux-btrfs/msg43831.html
[hr]

what’s not gonna help - seemingly SUPPRESSING compression is impossible:
[hr]

grub2 : “sparse file is not allowed”

ls -lash ## if a file has 2 diff. sizes —> sparse

4,0K -rw-r–r-- 1 root root 1,0K 7. Okt 19:17 grubenv # sparse :frowning:

sudo grub-editenv grubenv1 create # make a possibly sparse file
mv grubenv1 grubenv2
cp --sparse=never grubenv2 grubenv # un-sparse the file

btrfs property set /boot/grub/grubenv compression “”
btrfs property get /boot/grub/grubenv compression
#btrfs property set compression <zlib|lzo>

#compress never – if the NOCOMPRESS flag is set per-file/-directory :
chattr -c -V /boot/grub/grubenv # -R recursevly
lsattr /boot/grub/grubenv

chattr 1.43.6 (29-Aug-2017)
Flags of /boot/grub/grubenv set as -------------------

I don’t use btrfs. I’d say check the Manjaro forums, and/or Calamares site and bug tracker about this issue.

I researched it already, it is consired in the “wishlist” . sadly, the “save last entry as default” is not working on btrfs hence.

Yes, save last entry as default needs to be set to false, this is a known issue.

Look here:
https://forum.manjaro.org/t/grub-btrfs-error-sparse-file-not-allowed/2016

And especially here:
https://wiki.archlinux.org/index.php/GRUB/Tips_and_tricks#Recall_previous_entry

[quote]
This will only work if /boot is not a btrfs, because grub cannot write to btrfs. But it will generate a misleading error message: “sparse file not allowed. Press any key to continue.”. [/quote]

So your wishlist on this will need to be taken up with grub. :wink:

seems like this came up since 2011 already … :dodgy:

finally I found a bug.

the 2 extra buttons of a 5 button mouse do not work properly. They kinda work if pressed together with right or middle button .

on an older kubuntu, in comparison, all is fine on the same machine + mouse.

kinda bugged me since I had just gotten a new mouse … :dodgy:

Try removing imwheel.

wow, thanks ! that fixed it !

remove package imwheel , relogin --> test under configure desktop

excellent !

You might have some slow scrolling in certain Plasma containment’s or widgets, like wallpapers, and/or kickerdash without imwheel, these have not been updated to be compatible with libinput.

########## new issue ###########

after changing a few systemsettings via GUI, I got a desktop freeze 2 times.

[list]
[]only Alt-F2 KRunner would work, no other mouse button or stuff
[
]I narrowed the offending setting downto the ~/.config/plasma or startup or kwin settings.
[] :heart: turned out, the plasma files were producing the freeze.
[
]move them away, then the desktop will unfreeze. copy them back as needed later. :heart:
[/list]:dodgy:
[list]
[*]actually,
[/list]
[Theme]

name=air

[list]
[]inside of the file plasmarc killed my desktop !
[
]the :s “Air” theme is broken !
[]omg.
[
] :huh: who would have thought that :huh:
[/list]

[list]
[]removing those 3 groups of .rc files got the desktop going again, with loss of some settings unfortunately.
[
]so now I made a skeleton ~ dir in case this happens again. in case of reoccurance I’ll have to get to the root of this annoyance.
[]setting up a new user “adduser aa” will always give a working ~ though
[
]this clearly should not happen.
[/list]

We have no control over the air theme, I’m sorry it caused you an issue.

when copy plasmarc into ~/.config/ while being logged in, all looks fine at first, but

[list]
[]after relogin there will be freeze and
[
]CPU consumption will be 50% on some plasma file.
[*]Something is broken in “Air” which causes that.
[/list]

I’ve never changed my plasma theme from blackx, so I have no plasmarc file in my home directory, only our Netrunner default file is used under /usr/share/default-settings. Have you only tried the air theme so far? I’m thinking other themes based on air could also be affected.

I just wanted a light theme and use some Breeze-light theme now. I’m not sure which ones might be Air-derivates.