Ark cannot extract password-protected archives

Ark cannot extract password-protected archives. This bug is supposed to be fixed but I have this problem…

I have this version with kubuntu-backports enabled :

[code]$ dpkg -l | grep ark
ii ark 4:4.14.2-0ubuntu1~ubuntu14.04~ppa1 amd64 archive utility

$ ark -v
Qt : 4.8.6
Plate-forme de développement de KDE : 4.14.2
Ark : 2.19

What kind of password-protected archive are you trying to extract?
What is the exact error your getting?

It’s this file
Password : effeci2
No error when I extract it, ark don’t even ask the password. It just “extract” an empty file.
File-roller works

I just downloaded your file and It works here under Netrunner Rolling. I’ll need to do some research.

I hope you can find where the problem is.

On Rolling right now the version is 4.14.1-1 with 4.14.2 in the testing branch, I wonder if this is a bug in the newer version?
I’ll have to wait for the next update to find out I guess.

Any news on this ?

Still works on my machine, I don’t know why it isn’t for you.

I asked on the bug report for this issue and Raphael Kubo da Costa anwser this ( :

[quote]This specific sample you’ve attached seems to use a more recent archive format than infozip (which provides the zip and unzip commands) supports. If I invoke unzip manually on Debian sid, I get this:

skipping: turntable-music-hd-wallpaper-1920x1080-1781.jpg need PK compat. v5.1 (can do v4.6)

Now if I create a sample encrypted zip archive myself (zip -e turntable-music-hd-wallpaper-1920x1080-1781.jpg) and then try to extract it with Ark, I also get an empty archive. This is most likely caused by Debian having patched Ark to use libarchive instead of the infozip backend for zip files, and there’s no code in the libarchive backend to handle passwords. Distros like Ubuntu and NetRunner then inherited this patch.

This is a downstream problem, and I’d start with pinging your distro about this issue. Meanwhile, one workaround would be adding “application/zip;” back to the “MimeType” line in /usr/share/kde4/services/kerfuffle_clizip.desktop and then running “kbuildsycoca4”.[/quote]

I can’t follow that explaination as I don’t see any patch in the ark version shipped by ubuntu & netrunner. The debian jessie version has a patch to fix issues with zip creation in general with infozip.(maybe also because of older unzip in repo)

I know that unzip in the current trusty repo has problems with umlaute but not passwords. You could try upgrading to the unzip version provided by utopic to try if unzipping works with it:

PS: Added comment on kde bugtracker.

I tried with Utopic unzip version and it’s the same

Yeah I noticed that Kubuntu Backports PPA uses the libarchive patch in contrast to the official version 4.13 in trusty. So it might be really that this is causing the issue.
I am not sure if you can downgrade that package of ark. But its worth a try.

I tried version 4.13 ( and it works.

I send an email to kubuntu ppa maintainer with the form on launchpad but still no answer for a week.
Do you know how can I have ark fixed in kubuntu ppa ?