ATI/AMD x800 video out

I have an ATI x800 graphics card with video out. I want to use it to watch TV on an old CRT (with built-in digital ATSC/QAM tuner and component inputs, so it’s not that old). I will eventually upgrade to a nice HDTV (several months, at least). The VGA works. The s-video out works. When I boot, I am able to see the BIOS screen in S-Video on a TV (VGA off). The boot loader shows on both displays, turning on the VGA. Then, as soon as the boot loader screen disappears, the S-Video goes blue (no signal). In Netrunner 12.12.1 (32 and 64 bit), I am able to use VGA but not S-Video though it is listed in the Displays (as well as DVI which I don’t use). It is greyed out and I am only able to change VGA and see VGA. If I disconnect the VGA and start the PC, the S-Video dispalys the BIOS and boot loader, then goes blue. I looked for a proprietary driver and found at the ati site. This seems to be the latest driver that will work with this card in Linux. I have no idea what driver version Netrunner installed (or how to find out; I am a Linux noob/newb). Anyway, when I try to install the driver, I get an error.

[code]root@bthtpc:/home/bthtpc64/Desktop# sh ./ati-driver-installer-9-3-x86.x86_64.runCreated directory fglrx-install.jTGbsT
Verifying archive integrity… All good.
Uncompressing ATI Proprietary Linux Driver-8.593…

ATI Technologies Linux Driver Installer/Packager

Error: ./ does not support version
default:v2:x86_64:lib::none:3.5.0-22-generic; make sure that the version is being
correctly set by --iscurrentdistro

Removing temporary directory: fglrx-install.jTGbsT[/code]

Other than this, I am loving Netrunner as a non-Windows OS for those of us with a Windows-dependency. It is the only distro that seemed to be up to date enough to handle everything it should (especially AMD onboard graphics/HDMI audio). I really don’t want to resort to buying Windows just to watch TV. What’s funny is that even Windows 7 apparently does not have drivers for this card. Way to go AMD/ATI! If I can’t find a resolution for this I will resort to the dreaded VGA-to-TV adapter option which I’ve read isn’t so pretty. Any help is appreciated. Thank you.

Maybe I need help on Sigs too. Can’t find where to edit it. Here are my system specs, anyway.

CPU:AMD A4-5300
RAM:Team Xtreem Dark Series 8GB (2 x 4GB) DDR3 1600 (PC3 12800) TXD38192M1600HC9DC-D
GRAPHICS:Xtasy ATI Radeon X800 128MB

Well, here I am responding to my own post. This doesn’t bode well for Netrunner help, I guess. I am now using integrated graphics on the A4-5300 with one of those VGA-to-S-video thingies. This is working but I notice an issue with most videos in XBMC being laggy and affecting the cursor at the same time. I tried a flash drive version of Netrunner to install the Proprietary drivers I found listed under Additional Drivers. The first one listed (both are identical) errored out once downloaded (wouldn’t install). The second installed and then after restart showed a very messed up looking screen, all stretched and most of which was well below the viewable area of the TV. I could not access anything normally required to do any changes except the terminal which was still impossible to read. I wouldn’t know what to put in the terminal anyway. I went ahead and reinstalled Netrunner on the flash drive and am now hoping someone here can help in getting the proprietary drivers installed and working with an onboard VGA out. As it is after the driver update, I either can no longer use the monitor or TV or the screen is so distorted I can’t do anything to fix it. I don’t know if I can use fixes listed for Ubuntu or what should be changed (sudo…Quantal) if I do. Any help is appreciated.

Hi BrtrdSlag,

for any “uncommon” topic that might currently have none of the Netrunners out there experiencing too, you can always try Kubuntu Forums, Ubuntu, Debian or even general Linux, since Netrunner builds upon them and most of the solutions let’s say for Kubuntu work 99% of the time also in Netrunner. Hopefully, the more people use Netrunner and the Forums here, the more likely someone can help you directly here.

Okay. First, I am aware now that there are no Catalyst drivers for the x800 in newer versions of linux, so it’s a dead card for the purposes I was hoping to use it (the preinstalled Xorg driver works fine for VGA and DVI). On to the install of the Proprietary driver for a4-5300 APU graphics. Whether I do the Additional Drivers method or the Manual install method for Ubuntu Quantzal, once I restart, the screen looks terrible with most of it out of range of the screen. It is because it is trying to display 1600x1200 resolution on a 1024x768 max monitor (or vga to s-video out) so it isn’t looking right at all (this would not happen in Windows). I guess the solution would be to use a monitor that supported 1600x1200. I was able to open System Settings because I just so happened to have a link to it on the desktop. Then I resized the window so I could see most of it on screen. I scrolled down to Display… and opened that, resized the window and chose the last option (which is 640x 480) under the first dropdown. It is impossible to read on either of the displays I was using, but I knew that’s what it was. That allowed me to see the display and then change to 1024x768 which was the forth option from the bottom. After that, I restarted. I noticed that the very things I needed to change in the Catalyst Control Center conflicted with changes I was supposed to make in XBMC on their forums and wikis. So I changed those settings instead. The playback of files was exactly the same anyway so it was futile for me to attempt after all. The files are mpg2 files (DVD compliant) from QAM recordings that were edited in a program called DVBcut. There is no problem playing them in Windows XBMC with an Nvidia GTS 250. I’m only guessing but until AMD addresses the issues with its own drivers in Linux, there seems to be no fix. The CPU issue is also something not likely to improve since, even with the fixes listed in the XBMC forums for AMD CPU usage, the usage is still kind of high in best case. Strange, though, that I am able to watch these same files in VLC with zero lag or stalling. I tried various settings in XBMC with and without Catalyst drivers, but they all yielded the same or worse results. I will try Windows XP install on it next (I don’t have a Windows 7 disc) but that will be either Sunday night or later as I don’t have DVD drive or second HDD in the HTPC right now. At this point, I either put up with having to use VLC, or I buy an nvidia card (which may still leave the CPU issue) or buy Windows. I may try the forums, but that’s alot of data mining to go through. This is all adding up to time wasted that will just push me further and further down the Windows path. I should have gone with the Intel setup, I guess.

Well, I went full-bore into the HDD install (I’ve been doing testing outside of the HDD). First, I kept noticing “Eden” when loading XBMC, but was almost certain the latest version was “Frodo.” Why is Ubuntu so slow to update this in repositories? I mean really, what’s the point of a Software Center or Store or whatever if it’s not up to date? As an aside, I tried an install of Netrunner on my main PC and found the same graphics install issues with Nvidia drivers, only worse. It seems Ubuntu 12.10 isn’t just problematic because of Unity. Also, I had the same issue with playback in XBMC. This is what lead me to relize the discrepency in versions. So, back to the AMD build, I installed the latest stable release of XBMC (Frodo 12.1) by going to the website to download and following this guide for Ubuntu installation: Note the mention of different ppa’s you can choose as alternatives (xvba being one most Catalyst users may want to try). I had to input each line that starts with “sudo” one at a time. I did the default ppa. All was well, and more importantly, mpeg-2 playback was smooth. Then I went about installing the Catalyst drivers from the second listing under Additional drivers since it yields the same result as the manual install from the Ubuntu instructions (only without all of the terminal usage): I did the same thing listed in the previous post to change resolution (I will add here that I clicked the back arrow to force the “Apply or discard” pop up since the regular “Apply” button was off screen). I noticed that without Tear Free there was obvious tearing in playback of video in VLC/internet. I eventually turned Vertical Sync on in the Catalyst CC and left Tear Free disabled and that was good enough. Then I started adding skins to XBMC and tried them all. Big mistake, one of them caused a problem with the CPU load hitting 100% on one core or the other at all times. I later realized this was only happening in the interface, not the playback. I did all sorts of cleaning of addons and skins and stopped loading the Weather as the homepage and that finally brought it back to normal loads, but I still get 100% popping up in some interfaces. This was not a problem before I tried all the skins, so it isn’t the Weather thing that caused it, but the Weather thing is now possibly holding on to it. And now, somehow I am no longer able to get the right aspect ratio with 4:3 playback. I know it’s something I changed. I may just completely remove XBMC and reinstall it.

I will likely continue using VLC anyway, since I can’t easily give up the fast playback option (I like being able to play at 1.20x speed). There is no fast playback option in XBMC. But I still can’t stand having to reload the directory in VLC every time new files are added since it can’t update on its own (I use Media Library playlist so I can just start one and continue playing the next or skip to the next without leaving the playback, good for marathons). Every reload wipes all the data and that leaves no way to track what has been played. No resume function, either. I’m back and forth on the whole thing, obviously.

By the way, the VGA converter I’ve been using has always had this offset line that rolls down the screen every 45-50 seconds when playing video in any program (it is likely the device itself). It looks alot like the tearing seen with Tear Free and v-sync off but rolling down the screen except during camera changes. Oh, well. In a few more months I’ll by an HDTV and be done with that. I borrowed a 22" Emerson LED while testing. Wow… I don’t know what to say. It was bad. Fonts were especially harsh. Now I know why it was so easy to borrow. Hopefully a good Samsung or LG will have better desktop image. I guess this thread is useless now. Basically, x800 is too old to work on newer versions of Ubuntu. At least with Catalyst drivers or video out. It’s been made legacy by both AMD/ATI and Ubuntu. So, yeah, thread is useless other than giving me a place to put all this nonsense.

" It’s been made legacy by AMD/ATI"

I assume this is the bane of keeping this part proprietary:
If the main developer decides it’s legacy, then there’s not much anyone elso can do…