Auto login

How do you get auto login to work? It ignores the setting during installation as well as the settings in the System Settings GUI. :huh:

Auto login isn’t working with SDDM and systemd:

Known issues

Incompatibility with systemd
Affected DMs: Entrance, MDM, SDDM, SLiM
Some display managers are not fully compatible with systemd, because they reuse the PAM session process. It causes various problems on second login, e.g.:
NetworkManager applet does not work,
PulseAudio volume cannot be adjusted,
login failed into GNOME with another user.
See the following bugtracker reports for more details:
MDM: [1]
SDDM: [2] (fixed in git master), although it doesn’t work with autologin [3]
SLiM: [4] [5]

I copy and pasted from the bottom of: https://wiki.archlinux.org/index.php/display_manager

This is just a suggestion but, you might try switching to KDM.

Auto login with SDDM is working well for me with netrunner rolling installed in a Virtualbox virtual machine.

I just tried using the GUI to set up auto-login and it worked for me. did it ask for a password when you hit apply?

We fixed sddm up as we had autologin issues on the live media aswell. So it should now work also when installed.

@chief

Have you ran any updates since installation?
If not the first updates need to be run from the command line:

sudo pacman -Syuu

if you would like an icon in the system tray for update notifications you’ll need to install octopi-notifier.

PS. you should check for updates at the least every 2-3 weeks, most the time updates come in every week on Sunday, but can sometimes take much longer if there are any major issues (like the move to systemd or the symlinking of /bin, /sbin & /usr/sbin to /usr/bin). Manjaro tries to deal with any problems they find and correct them using the manjaro-system package so that their users don’t have to.

I have the old iso so I did a system update from Octopi. I went to System Settings Other and Login Screen. I have EnableAuto-Login checked and my user selected. I have Preselect User as Specified with my User selected. I have Enable Password-Less Login selected for my user. It still asks for a password at restart. What am I doing wrong?:huh:

The System Settings–> Advanced --> Other --> Login Screen is for KDM.
Use System Settings --> System --> Startup and Shutdown --> Login Screen for SDDM. The advanced tab has the auto login checkbox and a dropdown box to select the user.

Hmm… Maybe you need to manually edit the config file. Make sure to have the correct AutoUser=username and LastUser=username written in /etc/sddm.conf

Never had so much fun since the hogs ate my little sister :P:D Thanks that worked. Now off to load this puppl on my wife’s Laptop and see if I can network to Linux platforms.

[hr]
I have Kubuntu 14.10 KDE 5 plasma desktop. HAving THE hardest time getting to auto login.
Have read your thread above,I didn’t have some of these icon options in my systems settings I had to:

sudo apt-get install Login Screen (login screen SDDM)

I run login screen SDDM
NOW I have something that has the auto login check box!

However, when I check the box…and Apply, then click ok…its not saving
the changes, when I go back in, the box is unchecked!!

Is there a way to set auto login at the command line ?

The plasma 5 in combination with sddm is still in early development so such problems might occur.

You could check the config file directly in /etc/sddm.conf as far as I know the config option should be AutoLoginUser=username. Autologin itself then only works if the LastSession option is set to something valid.

My sddm.conf has no “AutoLoginUser=username” Can you tell me where in sddm.comf this would go and in any special format ?
Thanks AJ
Trying to attach my sdd.conf to this thread, if I can’t I’ll post it in another Reply just after this
[hr]

# SDDM
#
# The display manager service manages the X servers running on the
# system, providing login and auto-login services
#
# based on lightdm upstart script

description     "SDDM"
author          "Rohan Garg <rohangarg@kubuntu.org>"

start on ((filesystem
           and runlevel [!06]
           and started dbus
           )
          or runlevel PREVLEVEL=S)

stop on runlevel [016]

respawn
respawn limit 2 15

emits login-session-start
emits desktop-session-start
emits desktop-shutdown

script
    if [ -n "$UPSTART_EVENTS" ]
    then
        # Check kernel command-line for inhibitors, unless we are being called
        # manually
        for ARG in $(cat /proc/cmdline); do
            if [ "$ARG" = "text" ]; then
		plymouth quit || : 
                stop
		exit 0
            fi
        done

        [ ! -f /etc/X11/default-display-manager -o "$(cat /etc/X11/default-display-manager 2>/dev/null)" = "/usr/bin/sddm" -o "$(cat /etc/X11/default-display-manager 2>/dev/null)" = "/usr/sbin/sddm" ] || { stop; exit 0; }
        plymouth quit
        clear >/dev/tty7
    fi
    exec sddm
end script

post-start script
    sleep 5
    clear > /dev/tty7
end script

post-stop script
        clear > /dev/tty7
        sleep 1
        if [ "$UPSTART_STOP_EVENTS" = runlevel ]; then
                initctl emit desktop-shutdown
        fi
end script

I went back to one of my virtual machines that has 14.04 and plasma 4 on it…to the login screen, and enabled auto login and apply. When I go back in…it also does not save the setting. There has to be a way to have it auto login. I know there is because, I had it doing it on 14.04 and 14.10 (last week), before I formatted and started over.

I’ve about worn out google…still coming up with nothing. I know this is something very simple I’m over looking.

That looks not like the /etc/sddm.conf that you posted but a upstart service file that starts sddm.

[hr]
That is my sddm.conf file, I opened it and pasted it there.
What I want is after reboot, It NOT to ask for a password, just go straight into desktop.
I have Login Screen (login screen SDDM) installed but it won’t save the check box.
I update Kubuntu daily…if not more, i’m on latest version.

Can I cut to the chase. Please tell me in detail, how to do auto login?
Keep in mind, I’m relatively new to Kubuntu and may not know acronyms or where a file or setting is without instruction.

Thanks AJ

Kubuntu 14.10 Plasma5 ISO
[hr]
The end game for this, for me…is to have an app start when I login…if there is a way to have the app start before login, ie at op system start up,this would give me what I want.

I want real vnc to be running before the login, so I can vnc into the box, log in…and go on.

Looking at putting short cut in one of these:

/home/ajub2/.config/autostart)
/usr/share/autostart
/etc/xdg/autostart
/usr/share/upstart/xdg/autostart

Non of these have worked…I’m sure I’m not doing some little thing rite.
If you go to

http://www.aanning.com/2/

and click on

KU.doc

I’ve put together screen shots and verbage.

Any advise is greatly appreciated.

thanks AJ

Janning:
I guess no one is going to click on a .doc from the internet.
I suggest for this non-officially released Kubuntu ISO to ask directly in their forums below, since Netrunner doesn’t even have such an ISO to give support for:
http://kubuntuforums.net/

Otherwise I am not sure if someone here can help you with that “end-goal” of yours.

Hi, I thought about that…I agree on the .doc file…so so at

http://www.aanning.com/2/

I now have
KU.pdf
or
KU.htm

and all of the screen shots are there in the dir
I’d hate to have to start over in another forum,I have to be real close here?
thanks AJ