Back to Netrunner | Back to Blue Systems

automounter mounts ntfs USB drive with root ownership

I have a USB thumb drive which is formatted with fat32. Ubunutu and Linux Mint both mount it when it’s plugged in with regular user permissions, as expected. When I plug it into my Netrunner Rolling 2017.07 laptop, it is mounted with root ownership. This prevents writing to the drive as a normal user.

Ideally, Netrunner should mount fat32 drives with user ownership and read/write permissions. If there’s a place I should enter a feature request for this I will happily do so. In the meantime, is there a workaround to fix the automounter? I’d rather fix the automount system config than write a custom line in /etc/fstab. Thanks!

Manjaro (arch) have a stricter policy when it comes to users and file system access than Ubuntu based systems. However, I have never seen this issue with any of my fat32 formatted usb drives. I’d suggest performing a search, or making an inquiry on the Manjaro forums for the issue you’re having.

I have to ask though:
Have you tried running an fsck on the drive?
(There could just be some filesystem errors on the drive.)

Have you rebooted your system after the latest system update?
(Sometimes kernel, udisk2, dbus, ACL (access control library), and other core system updates can cause issues like this)

In the meantime I’ll try to reproduce your issue.

Thank you for responding quickly and for the courtesy in your reply. (Since that’s not always the case in all forums I like to thank people who take the time to be helpful and who are kind).

After a closer look a the drive, I realize it’s formatted ntfs, not fat32 as I had assumed. I have updated the thread topic. My apologies for the confusion.

I have tried your suggestions, and done (more) research and searching of the manjaro forums. Here are my results:

  • Unfortunately I didn’t find a relevant topic on the manjaro forums (other than “format as fat32” which doesn’t solve the problem with ntfs)

  • Made sure the system is up to date and rebooted

  • Ran fsck on the drive - completed and found no errors

  • Re-inserted the drive in the Netrunner laptop, it’s still mounted with root ownership

  • Inserted the drive into a laptop running Linux Mint - it is mounted with non-root regular user ownership as expected

First, ntfs-3g should be installed by default, but I’d check just in case something uninstalled it.

Second, make sure the drive was unmounted correctly or the drive can be locked, or end up with file system errors, this will cause ntfs-3g to mount the drive read only.

NTFS drive also can not be fixed with fsck and requires windows chkdisk, or a special tool under Linux.
try this:

[code]# umount /dev/sdb1

ntfsfix /dev/sdb1[/code]

You’ll need to change /dev/sdb1 to the correct drive (a,b,c) and partition (1,2,3) location for your external drive in relation to where your drive is pluged into your system.

If this does not fix the issue, it could be due to the fact that Arch does not compile ntfs-3g with fuse support.

I don’t have any ntfs formatted external drives atm, I usually use ext4 or fat32, but I will try to find a spare usb stick to test with.

Sorry for the delay in my response and thank you for the new suggestions.

ntfs-3g was installed. I always unmount the drive correctly through the devices icon in the system tray or the eject icon in the file manager.

In my earlier response, when I said I ran fsck, I had actually checked the drive for errors in Windows. chkdisk found no errors. (I think fsck was from an earlier draft of my message and I forgot to update that text)

I have installed ntfs-3g-fuse (which replaces ntfs-3g) but the drive is still mounted with root permissions. As an aside, if this package is necessary to mount ntfs removable drives with user ownership I’m curious why it is not installed with a default Netrunner installation.

AUR package, and I’ve not had this issue to date. The times I did have this issue it had to do with the way the partition was made on the drive and not the file system itself. Wish I could be of more help but without being able to reproduce the issue makes it tough, I’m more or less reliying on information I can find on-line and in the Manjaro (Arch) forums.

I finally got a chance to do more testing on this. After formatting the drive with ntfs on Linux Mint, it is mounted with user ownership as expected with NetRunner. I was able to write files normally. Just to be thorough I reformatted it using Windows to ntfs and it also behaved as expected with NetRunner. I’m pretty sure the format I had done before starting this thread was on Windows. While I’d prefer being able to pinpoint the root cause of the initial problem, I’ll happily settle for things working. Thanks again for your responses and for helping out. If anything changes I’ll update the thread.

Yea, strange how that works out sometimes.