Autostart Program doesn't stick

Trying to add Basket Notes to startup in system tray.

But when I reboot the entry is missing and no basket notes running.

Click on menu entry runs fine.

I just tried on my end and was able to add applications to the startup using the GUI without issue, they were still there after reboot.
How did you install basket notes?
Did you get a permissions error when adding basket in startup?
I had this same problem with trying to add Libre Office applications to startup, the .desktop files in /usr/share/applications are just symlinks to /usr/lib/libreoffice/share/xdg/base.desktop causing the issue with them.

Yep that is where I installed it from.
And as I remember had this issue also when trying to add Conky.
But now Conky is sticking and no issue.
Will have to investigate closer and try to remember what I did to get Conky to stick.
As is creating a kde4-basket.desktop when I add it to startup.
When it disappears on reboot the kde4-basket.desktop is there.
As asks me if I want to overwrite it when I re-add it to startup.

I updated my previous post.
Have you tried copying the .desktop file manually to ~.config/autostart and setting the appropriate file permissions?
The .desktop file for basket can be located here: usr/share/applications/kde4/basket.desktop.

Nope finally got it to work

Manually in the add program typed basket instead of picking from drop-down menus.
Added the -h option to start hidden so doesn’t open on desktop on startup.
And it ran fine. And yep seems a bug? for me anyways selecting apps from drop-down menus.
Versus typing name of app manually.

If I do it manually my permissions for it are and even the executable flag isn’t selected but works anyway.

If I select basket from the dropdown menus I get it all grayed out and executable flag is selected.

So at this point a bit confused. As other programs if I use dropdown menus for krita,darktable,etc…
Seem to have the manual config with permissions showing not grayed out like basket.
And not all menu items are equal. If i try to add LibreOffice or LiberWriter it has no permissions says they are links.
And have no permissions so seems the menu items are not all the same?

The permissions are not always forbidden on group or others.
Maybe there is an issue with the actual .desktop file in usr/share/applications/kde4/.

I see your still in the users group, manjaro changed this recently and put all users in their own group.
This change doesn’t carry over to already created users, try changing your user group to orbmiser and see if that helps.

sudo groupadd orbmiser
sudo usermod -g orbmiser orbmiser

I’ve also noticed that sometimes I had to go back in and hit OK a second time before the command field would be filled in the autostart GUI.

Did the commands and wonder why that wasn’t in an update?
As would never have looked there not knowing I had a problem.

Ohhh Well thanks for the help and fix. Got Basket Notes working tho concerned with longevity as haven’t been worked on in like 2years?
May end up uninstalling and trying Cherry Notes instead. Just checking out light tray based notes type programs.

I don’t know cherrytree is python GTK based.
Have you looked a qownotes?
There is also qtnote:
I was able to download, build and install this one manually, it integrates nicely in the plasma5 system tray, and has a start with system in it’s own options. However, there doesn’t seem to be a AUR entry for this one, which is too bad.
Maybe if I can find time when I’m home this weekend I’ll make a pkgbuild for it, I think this would be a nice edition for my sons Manjaro LXQT install.

Yep alot less feature rich versus the others.
And yep there is a ding given it being Gtk but if basket notes doesn’t work out then probably the one next.
As both are feature rich with features I may need if it pans out as a daily driver I use thing.
Basket Notes would be wonderful if it got a Qt facelift and rewrite instead of just a port over to Qt frameworks.

Tho confused as basket notes on the web site shows Basket 2.0 Beta 2.
But repo shows 1.81-7 which is older version has a apr 2016 build?
Confusing as basket notes hasn’t been upgraded in 2 years?

Ahhh scrolled down to bottom and got clarification.
[2010-09-30] Basket 2.0 Beta 2 (1.81) Released
Wish they wouldn’t play with numbers like that.