Black screen on boot-up! Have I been plasma-cized? [Solved]

:frowning: NetRunner 14.5 LTS installed OK. I decided to add some Plasma(?) icons to the toolbar to allow me to monitor my system (CPU, memory, etc). Now when I boot up the screen is black with only the cursor, and I only see a couple of messages re my battery state and my DSL connection. Can’t get much done with a blank screen! Any ideas? Can I kill Plasma?

Should perhaps add that I used NetRunner successfully for several days before deciding that I wanted a task manager display to determine when I would have a successful Dansguardian filter running on my system. I added about a dozen of the cute monitor programs (and the pair of eyes to show my grandkids) before I started having problems. I would delete all of those if I could just get my desktop back!

Can you press ALT+F2 does it bring up krunner? Can you see in ksysguard if plasma-desktop is still running. If it isn’t try starting it in krunner.

ALT+F2 did bring up krunner. ksysguard shows me that plasma-desktop has one of my processors locked up 100%. I guess I’m plasma-cized. What now, please?

Can you kill that process and try restarting it. If it does hang again kill the process again and rename the file ~/.kde/share/config/plasma-desktop-appletsrc.
WARNING this will reset your widget config on the desktop. So you have to start from scratch here.
After that try again launching plasma-desktop

Thanks. Killing the process and restarting it worked, and I’m using the system now for this forum update. Should I do a binary search to determine which icon causes the issue, or would that be a waste of time (it could take quite a while)? How may I help?

Try testing if it still works after a restart and it would help if you could determine which widget is causing this issue (maybe something that can be reproduced and then hopefully can be fixed)

The widget that causes the problem is “Remember the Milk…” which apparently requires some set-up on the internet which I did not notice. I think that the widget needs to report that it is not ready for use by posting a message to the screen, and then exiting.

It’s not a widget I need, so all is well for the moment. Thank you for your timely help!

Thanks for investigating :slight_smile: