Brother DCP-7065DN Lazer install

Well when i plug in this printer my computer makes an attempt to retrieve the drivers online and fails. Then I get the ones from the brother website but when i try to install it fails as well. I suppose there is something in pacaman but I am not sure what to look for. Thanks in advance for any one pointing me in the right direction.

first make sure the firmware is up to date:
http://support.brother.com/g/b/downloadlist.aspx?c=us_ot&lang=en&prod=dcp7065dn_all&type2=4&os=92

Those drivers are available in the AUR:

yaourt -S brother-dcp7065dn

for the scanner part:

yaourt -S brscan4

scanner over network:

yaourt -S brscan4-network

for the brother scan key tool:

yaourt -S brscan-skey

Thanks for the reply.
In the end it tells me that PACMAN is being used.

==> Downloading brother-dcp7065dn PKGBUILD from AUR…
x PKGBUILD
x lpr-license.txt
x brother-dcp7065dn.install
x cupswrapper-license.txt
Anonymous comment (2014-04-08 13:08)
@nowaker, this is a bit of a problem, the brother drivers are 32-bit only.
On ARCH64 (wich burntsushi was using) you have to activate multilib.
See: https://wiki.archlinux.org/index.php/Multilib

Comment by Nowaker (2014-05-12 20:09)
@libernux I know multilib needs to be activated, but the driver should explicitly state it needs it. Otherwise people have to debug why the driver doesn’t work just to find out multilib needs to be installed. This is what dependencies are for. :wink: Official PKGBUILD guidelines even give an example. https://wiki.archlinux.org/index.php/PKGBUILD#arch

Anonymous comment (2014-05-12 20:21)
@nowaker I updated the build to include the dependency for lib32-glibc if arch = x86_64

Comment by Nowaker (2014-05-12 20:51)
Thanks! Be sure to perform the same thing to every Brother package.

Comment by sprudel (2014-10-25 17:08)
Duplex printing does not work.
It always prints two pages instead of one.
Any idea?

brother-dcp7065dn 2.0.4-2 (Mon Apr 7 15:44:08 AST 2014)
This package is orphaned
( Unsupported package: Potentially dangerous ! )
==> Edit PKGBUILD ? [Y/n] (“A” to abort)
==> ------------------------------------
==> n

==> brother-dcp7065dn dependencies:

  • cups (already installed)
  • lib32-glibc (already installed)

==> Edit brother-dcp7065dn.install ? [Y/n] (“A” to abort)
==> -----------------------------------------------------
==> n

==> Continue building brother-dcp7065dn ? [Y/n]
==> -------------------------------------------
==>
==> Building and installing package
==> Making package: brother-dcp7065dn 2.0.4-2 (Sat Dec 13 16:35:30 AST 2014)
==> Checking runtime dependencies…
==> Checking buildtime dependencies…
==> Retrieving sources…
-> Downloading dcp7065dnlpr-2.1.0-1.i386.rpm…
% Total % Received % Xferd Average Speed Time Time Time Current
Dload Upload Total Spent Left Speed
100 37729 100 37729 0 0 156k 0 --:–:-- --:–:-- --:–:-- 156k
-> Downloading cupswrapperDCP7065DN-2.0.4-2.i386.rpm…
% Total % Received % Xferd Average Speed Time Time Time Current
Dload Upload Total Spent Left Speed
100 14697 100 14697 0 0 74424 0 --:–:-- --:–:-- --:–:-- 74604
-> Found cupswrapper-license.txt
-> Found lpr-license.txt
==> Validating source files with md5sums…
dcp7065dnlpr-2.1.0-1.i386.rpm … Passed
cupswrapperDCP7065DN-2.0.4-2.i386.rpm … Passed
cupswrapper-license.txt … Passed
lpr-license.txt … Passed
==> Extracting sources…
-> Extracting dcp7065dnlpr-2.1.0-1.i386.rpm with bsdtar
-> Extracting cupswrapperDCP7065DN-2.0.4-2.i386.rpm with bsdtar
==> Starting prepare()…
==> Entering fakeroot environment…
==> Starting package()…
==> Tidying install…
-> Purging unwanted files…
-> Removing libtool files…
-> Removing static library files…
-> Compressing man and info pages…
-> Stripping unneeded symbols from binaries and libraries…
==> Creating package “brother-dcp7065dn”…
-> Generating .PKGINFO file…
-> Adding install file…
-> Generating .MTREE file…
-> Compressing package…
==> Leaving fakeroot environment.
==> Finished making: brother-dcp7065dn 2.0.4-2 (Sat Dec 13 16:35:31 AST 2014)

==> Continue installing brother-dcp7065dn ? [Y/n]
==> [v]iew package contents [c]heck package with namcap
==> ---------------------------------------------------
==> y

==> Pacman is currently in use, please wait.

OK, make sure your system is up to date first.

(step 1) If you have not performed the bash upgrade yet do this first:

sudo rm -R /var/lib/pacman/local/bash-4.3.024-1

(step 2) otherwise skip to here:

sudo pacman -Syy sudo pacman -S bash pacman manjaro-system sudo pacman -Su

if your still getting the same error then do this first then go back to step 2:

sudo rm /var/lib/pacman/db.lck

(step 3) next install the base development packages

sudo pacman  -S base-devel

(step 4) Now, you should be able to install your printer and scanner drivers.

Ok I guess we are almost there.
I ran the commands and all of the sudden i had 433 upgrades that needed to be done. So I went through the process and was able to install the drivers afterwards.
All of the sudden my fan is going crazy and it must be some kind of process because when i go into my windows partition it shuts off.
Also the computer sees the drivers but when i send a print job to it nothing happens (same with the scanner.

OK, that update was expected, the printer issue was already discussed on the Manjaro forum, cups 2.0 changed it’s systemd service file name, here is what you need to do:

sudo systemctl enable org.cups.cupsd && sudo systemctl start org.cups.cupsd

The scanner sometimes takes a while after installing the driver before it shows up in simple-scan or skanlite, a reboot is often required.

Well those codes went through no problem although I am still not being able to get the printer to work. When I went to settings page it has 7065DN as printer name but it has the 7045DN drive when I try to change it for the 7065DN it brings up the password prompt and will not let me type anything to it and then it freezes a few minutes later.

Oh yes and my fan is still going like a fighter jet. I didnt see anything in the system monitor CPu use ranges from 1%-3% so it doesnt make sense. Thanks for you assistance so far. I hope we can tackle this. :slight_smile:

There is a brother-dcp7045n driver in the AUR, maybe a typo?

I wonder if the fan noise coming from the CPU or the GPU fan?
What is your display chip-set and are you running free or non-free drivers for it?

Could you post the output from inxi -F

System: Host: XXXX Kernel: 3.16.7.2-1-MANJARO x86_64 (64 bit) Desktop: KDE 4.14.3
Distro: ManjaroLinux 0.8.11 Ascella
Machine: System: TOSHIBA product: PORTEGE R835 v: PT324U-02U00R
Mobo: TOSHIBA model: Portable PC v: Version A0 Bios: TOSHIBA v: Version 3.80 date: 06/22/2012
CPU: Dual core Intel Core i5-2435M (-HT-MCP-) cache: 3072 KB
clock speeds: max: 3000 MHz 1: 2800 MHz 2: 2799 MHz 3: 2958 MHz 4: 2861 MHz
Graphics: Card: Intel 2nd Generation Core Processor Family Integrated Graphics Controller
Display Server: X.Org 1.16.2 driver: intel Resolution: 1366x768@60.17hz
GLX Renderer: Mesa DRI Intel Sandybridge Mobile GLX Version: 3.0 Mesa 10.3.4
Audio: Card Intel 6 Series/C200 Series Family High Definition Audio Controller driver: snd_hda_intel
Sound: Advanced Linux Sound Architecture v: k3.16.7.2-1-MANJARO
Network: Card-1: Intel 82579V Gigabit Network Connection driver: e1000e
IF: enp0s25 state: down mac: XXXXXXXXXXX
Card-2: Intel Centrino Wireless-N 1000 [Condor Peak] driver: iwlwifi
IF: wlp4s0 state: up mac: XXXXXXXXXX
Drives: HDD Total Size: 256.1GB (8.7% used) ID-1: /dev/sda model: SAMSUNG_SSD_830 size: 256.1GB
Partition: ID-1: / size: 12G used: 9.6G (83%) fs: ext4 dev: /dev/sda5
ID-2: /home size: 94G used: 7.5G (9%) fs: ext4 dev: /dev/sda6
ID-3: swap-1 size: 1.03GB used: 0.00GB (0%) fs: swap dev: /dev/zram0
ID-4: swap-2 size: 1.03GB used: 0.00GB (0%) fs: swap dev: /dev/zram1
ID-5: swap-3 size: 1.03GB used: 0.00GB (0%) fs: swap dev: /dev/zram2
ID-6: swap-4 size: 1.03GB used: 0.00GB (0%) fs: swap dev: /dev/zram3
Sensors: System Temperatures: cpu: 64.0C mobo: N/A
Fan Speeds (in rpm): cpu: N/A
Info: Processes: 181 Uptime: 2 min Memory: 930.0/7892.1MB Client: Shell (bash) inxi: 2.2.16

Why did you upgrade your kernel to 3.16 it does not load the Intel microcode?
https://forum.manjaro.org/index.php?topic=17617.msg162502#msg162502

you’ll need to upgrade to 3.17 or 3.18 or go back to the 3.14 LTS.

Hello my knowledge with this is very limited. I intend to take some classes because I really like it but for now I will have to enjoy of your assistance on this one as well. I am not sure how I got Kernel 3.16.
I would like to get whichever one you recommend also I would need how to do it. I found some instructions online but the guy was doing it from ubuntu so i think its a bit different.
Thanks Again
[hr]
I used the sudo mhwd-kernel -i linux317 command. Ill let you know if I see any improvement.

You can also go into Menu > Settings > Manjaro System Settings > Kernel and manage your kernels there:
[attachment=545]

Since Netrunner Rolling is based on Manjaro Linux you can also refer to their wiki page here:
https://wiki.manjaro.org/index.php?title=Main_Page

I switched to 17 and no changes. Then I switched to 14 and still the same. I found this link following the ones you gave me but it seems like it is a bit advanced for me. any chance you can dumb it down?
https://wiki.archlinux.org/index.php/Microcode#Enabling_Intel_Microcode_Updates
Thanks again
PS
Is there any chance that if I reload the OS it will end up acting the same?

I had forgotten that cups 2.0 changed it’s service file name:

systemctl disable cups.service systemctl enable org.cups.cupsd.service systemctl daemon-reload systemctl start org.cups.cupsd.service

OK this is what I have done so far.

  1. Reloaded netrunner- The fans were driving me crazy.
  2. Did the first step of installing the driver.
  3. once i did it toldto reload cups- i tried a couple of ways but no progress
  4. Then I tried
    systemctl disable cups.service
    systemctl enable org.cups.cupsd.service
    systemctl daemon-reload
    systemctl start org.cups.cupsd.service[/code]
    5.And it would not take this line of code so then I found this wiki
    https://wiki.archlinux.org/index.php/Brother_DCP-7065DN
    6.I made it to
    Extract both RPM files :

$ rpmextract.sh dcp7065dnlpr-2.1.0-1.i386.rpm
$ rpmextract.sh cupswrapperDCP7065DN-2.0.4-2.i386.rpm

  1. Once i punch this code in i get…
    No package supplied and command not found for the second line.
    Help!

what line of code this:

If so then you need to remove the last bit like this:

systemctl start org.cups.cupsd.service

The arch wiki way isn’t going to work and is way too complicated, install the drivers as you did prior.
Let me give you all the commands needed to get the printer and scanner working:

sudo pacman -S bass-devel yaourt -S brother-dcp7065dn yaourt -S brscan4
reboot

systemctl disable cups.service systemctl enable org.cups.cupsd.service systemctl daemon-reload systemctl start org.cups.cupsd.service

OK did what you said.
I see the driver now loaded in the printer systems setting section and the scanner as well.
So it was a step in the right direction
Now i see a status on the printer systems setting section that says:
“Waiting for peinter to become available”
I did some reading and it has to do with the usb connection
I tried to do what it says here:
https://forum.manjaro.org/index.php?topic=4053.0
But i get a message that:
ATTR: Not an editor command
So maybe you could show the correct command for this distro.
THANKS:D

First make sure you have a2ps installed, all brother drivers require this for parsing the documents:

sudo pacman -S a2ps

Most of that is correct, however you wouldn’t have gedit installed in KDE by default, that is a gnome text editor, in KDE we have kate, also it’s never a good idea to use sudo for a GUI tool.

Here is what you should use:

kdesu kate /etc/udev/rules.d/10-usbprinter.rules

IT WORKED!!! IT WORKED!!! :smiley:
Pardon my excitement. :blush:
I guess you can put this one up as solved.
Thank you
Thank you

No need to apologize, I’m just glad I was able to be of assistance.
I’d also like to wish you a marry and joyful Christmas holiday season.