Cannot boot from an NRR 2016.01 USB drive

I am trying to set up NRR 2016.01 on a Lenovo G570 laptop from a USB drive with NRR 2016.01 written using the SUSE Studio ImageWriter on a desktop . On booting, I have chosen (Using F12) to boot from the USB drive.

All that happens is that I am returned to the boot device selection menu once more in a never-ending loop.

Booting off a DVD leads to a very slow boot with a lot of DVD ROM activity (sounds from the drive).

Why is booting from the USB drive failing? It would make the installation a much faster process if I could do that.


Did you tried disable uefi secure boot in efi/bios.
Also when available I would recommend using Bios compatibility mode for booting that should work best.

The Lenovo G570 BIOS does not have secure boot or UEFI, nor does it feature legacy mode.

Indeed, I have succeeded in installing NRR 2016.01 from DVD on it without any hassles, except a slow installation duration. I am perplexed why the laptop does not boot from the USB disk.

Strangely, I was able to boot from another USB drive but this time generated by the dd command rather than from SUSE Studio ImageWriter. I have not tested this out with the original USB drive to find out where the problem lies: USB drive or ISO writing program.

Sound to me that it would more than likely be a bad USB drive (stick).
Try using image writer with the know to be good stick and see what happens.
USB pen driver (aka memory sticks, flash drive, etc.) do have a finite number of write or erase cycles before they begin to fail.
They are also susceptible to environmental conditions (heat, cold, pressure, etc.)

It gets curiouser and curiouser.

I have now tried two USB drives with two laptops with these results:

                           Lenovo G570        Lenovo ThinkPad Edge E545

Strontium Pollex 4GB       Does not boot      Boots

San Disk 8GB               Boots              Boots

Both devices were written with dd and the fact that each drive is bootable on at least one laptop means that a hardware problem in either USB drive may be fairly discounted.

I think that the BIOS on the G570 does not play well with the Strontium Pollex drive for reasons not fathomable to me.

Does writing an ISO image entail a filesystem? I have used the same command to write into both drives:

sudo dd if=/path/to/ISO of=/dev/sdc bs=4k

I would far prefer it if any USB drive I had were bootable on any laptop that were configured in legacy mode with a boot option from a USB drive.

The ISO image is a hybrid image (UEFI compatible fat16 + ISO9660).
It requires that the image be written to the USB device in raw mode to function properly.

Would the above command:

sudo dd if=/path/to/ISO of=/dev/sdc bs=4k

ensure that the USB drive is written in raw mode?

When I examine both USB drives using KDE PartitionManager, I see similar outputs:

(a) a 31 MiB fat16 partition with the label MISO_EFI

(b) an unallocated segment of unknown type representing the rest of the drive


Yes, that would be correct.
I think you may be right about the BIOS of the G570 and/or the firmware of the stick could have an issue on that system.