Netrunner Home

Cannot install digikam


#1

Hi, my first post. Installed debian-based 17.06 a few days ago to replace Mint KDE Plasma. Very happy with the switch. Tried to install digikam but got an error message. From the terminal:

[code]snowdust@karibou:~$ sudo apt-get install digikam -o “Debug::pkgProblemResolver=1”
[sudo] password for snowdust:
Reading package lists… Done
Building dependency tree
Reading state information… Done
Starting pkgProblemResolver with broken count: 1
Starting 2 pkgProblemResolver with broken count: 1
Investigating (0) digikam-private-libs:amd64 < none -> 4:5.3.0-1 @un uN Ib >
Broken digikam-private-libs:amd64 Depends on libmarblewidget-qt5-25:amd64 < none | 4:16.08.3-1 @un uH > (>= 4:15.12.0)
Considering libmarblewidget-qt5-25:amd64 0 as a solution to digikam-private-libs:amd64 1
Holding Back digikam-private-libs:amd64 rather than change libmarblewidget-qt5-25:amd64
Investigating (0) kipi-plugins:amd64 < none -> 4:5.3.0-1 @un uN Ib >
Broken kipi-plugins:amd64 Depends on digikam-private-libs:amd64 < none | 4:5.3.0-1 @un uH > (= 4:5.3.0-1)
Considering digikam-private-libs:amd64 1 as a solution to kipi-plugins:amd64 0
Holding Back kipi-plugins:amd64 rather than change digikam-private-libs:amd64
Investigating (1) digikam:amd64 < none -> 4:5.3.0-1 @un puN Ib >
Broken digikam:amd64 Depends on digikam-private-libs:amd64 < none | 4:5.3.0-1 @un uH > (= 4:5.3.0-1)
Considering digikam-private-libs:amd64 1 as a solution to digikam:amd64 9999
Reinst Failed early because of libastro1:amd64
Reinst Failed because of libmarblewidget-qt5-25:amd64
Broken digikam:amd64 Depends on kipi-plugins:amd64 < none | 4:5.3.0-1 @un uH > (= 4:5.3.0-1)
Considering kipi-plugins:amd64 0 as a solution to digikam:amd64 9999
Reinst Failed because of digikam-private-libs:amd64
Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
digikam : Depends: digikam-private-libs (= 4:5.3.0-1) but it is not going to be installed
Depends: kipi-plugins (= 4:5.3.0-1) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.
snowdust@karibou:~$
[/code]

Any tips, pointers to help solve this issue are welcome.
Congrats to the developers for a rock solid distro.


#2

Thanks for all the help.


#3

Perhaps info in this post could be helpful: [Solved] Digikam 5.3 unmet dependencies


#4

That does not resolve the digikam installation for me. always unable to install digikam.
SM


#5

Yes, again the Digikam install is botched.
A work-around could be the AppImage explained in post#5

[code]sudo apt-get install digikam -o “Debug::pkgProblemResolver=1”
Reading package lists… Done
Building dependency tree
Reading state information… Done
Starting pkgProblemResolver with broken count: 1
Starting 2 pkgProblemResolver with broken count: 1
Investigating (0) digikam-private-libs:amd64 < none -> 4:5.6.0-3 @un uN Ib >
Broken digikam-private-libs:amd64 Depends on libmarblewidget-qt5-25:amd64 < none | 4:16.08.3-1 @un uH > (>= 4:15.12.0)
Considering libmarblewidget-qt5-25:amd64 0 as a solution to digikam-private-libs:amd64 2
Holding Back digikam-private-libs:amd64 rather than change libmarblewidget-qt5-25:amd64
Investigating (0) kipi-plugins:amd64 < none -> 4:5.6.0-3 @un uN Ib >
Broken kipi-plugins:amd64 Depends on digikam-private-libs:amd64 < none | 4:5.6.0-3 @un uH > (= 4:5.6.0-3)
Considering digikam-private-libs:amd64 2 as a solution to kipi-plugins:amd64 1
Holding Back kipi-plugins:amd64 rather than change digikam-private-libs:amd64
Investigating (1) digikam:amd64 < none -> 4:5.6.0-3 @un puN Ib >
Broken digikam:amd64 Depends on digikam-private-libs:amd64 < none | 4:5.6.0-3 @un uH > (= 4:5.6.0-3)
Considering digikam-private-libs:amd64 2 as a solution to digikam:amd64 10001
Reinst Failed early because of libastro1:amd64
Reinst Failed because of libmarblewidget-qt5-25:amd64
Broken digikam:amd64 Depends on kipi-plugins:amd64 < none | 4:5.6.0-3 @un uH > (= 4:5.6.0-3)
Considering kipi-plugins:amd64 1 as a solution to digikam:amd64 10001
Reinst Failed because of digikam-private-libs:amd64
Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
digikam : Depends: digikam-private-libs (= 4:5.6.0-3) but it is not going to be installed
Depends: kipi-plugins (= 4:5.6.0-3) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.[/code]