Cannot update pepperflash

According to Adobe’s version control site I have pepperflash 21,0,0,216 installed but the newest version is So I tried to update and this is what I get:

sudo update-pepperflashplugin-nonfree -iv options : -i -v -- temporary directory: /tmp/pepperflashplugin-nonfree.i7agKD3T3Q doing apt-get update on google repository cleaning up temporary directory /tmp/pepperflashplugin-nonfree.i7agKD3T3Q ... ERROR: failed to retrieve status information from google : W: Es gibt keine öffentlichen Schlüssel für die folgenden Schlüssel-IDs: 1397BC53640DB551 More information might be available at:

Packages are current, browser-plugin-freshplayer-pepperflash is version 0.3.2-1 and pepperflashplugin-nonfree 1.7ubuntu1.

I even tried to add the key to apt database by

[code]root@panther:/home/susan# gpg --keyserver --recv-keys 640DB551

gpg: Verzeichnis /root/.gnupg' erzeugt gpg: Neue Konfigurationsdatei/root/.gnupg/gpg.conf’ erstellt
gpg: WARNUNG: Optionen in /root/.gnupg/gpg.conf' sind während dieses Laufes noch nicht wirksam gpg: Schlüsselbund/root/.gnupg/secring.gpg’ erstellt
gpg: Schlüsselbund `/root/.gnupg/pubring.gpg’ erstellt
gpg: Schlüssel 640DB551 von hkp-Server anfordern
gpg: /root/.gnupg/trustdb.gpg: trust-db erzeugt
gpg: Schlüssel D38B4796: Öffentlicher Schlüssel “Google Inc. (Linux Packages Signing Authority)” importiert
gpg: Keine uneingeschränkt vertrauenswürdigen Schlüssel gefunden
gpg: Anzahl insgesamt bearbeiteter Schlüssel: 1
gpg: importiert: 1 (RSA: 1)
root@panther:/home/susan# gpg --armor --export 640DB551 | apt-key add -
root@panther:/home/susan# apt-get update

Didn’t change anything. And why is a different key D38B4796 added than 640DB551 ?

EDIT: Please try this first before the things I wrote underneath.

Download and update the gpg key signing thing for the original pepperflash updater as root with

cd ​/usr/lib/pepperflashplugin-nonfree
wget -q -O - > pubkey-google.txt

After that try the normal update mechanism again.

I think the script is simply wrong.
Can you try this here a.k.a.

# Copyright (C) 2006-2013 Bart Martens <>
# This program is free software: you can redistribute it and/or modify
# it under the terms of the GNU General Public License as published by
# the Free Software Foundation, either version 3 of the License, or
# (at your option) any later version.
# This program is distributed in the hope that it will be useful,
# but WITHOUT ANY WARRANTY; without even the implied warranty of
# GNU General Public License for more details.
# You should have received a copy of the GNU General Public License
# along with this program.  If not, see <>.
set -e
arch=`dpkg --print-architecture`
UNPACKDIR=`mktemp -d /tmp/pepperflashplugin-nonfree.XXXXXXXXXX`
wgetoptions="$wgetoptions -O $UNPACKDIR/$debfile" # to change wget message : Saving to ...
HOME=/root wget $wgetoptions $deburl 
dpkg-deb -x $debfile unpackchrome
[ -e $sofile ] || sofile=unpackchrome/opt/google/chrome-unstable/PepperFlash/
[ -e $sofile ] || sofile=unpackchrome/opt/google/chrome-beta/PepperFlash/
[ -e $sofile ] || sofile=unpackchrome/opt/google/chrome/PepperFlash/
mv -f $sofile /usr/lib/pepperflashplugin-nonfree
chown root:root /usr/lib/pepperflashplugin-nonfree/
chmod 644 /usr/lib/pepperflashplugin-nonfree/
[ -e $jsonfile ] || jsonfile=unpackchrome/opt/google/chrome-unstable/PepperFlash/manifest.json
[ -e $jsonfile ] || jsonfile=unpackchrome/opt/google/chrome-beta/PepperFlash/manifest.json
[ -e $jsonfile ] || jsonfile=unpackchrome/opt/google/chrome/PepperFlash/manifest.json
if [ -e $jsonfile ]
    mv -f $jsonfile /usr/lib/pepperflashplugin-nonfree
    chown root:root /usr/lib/pepperflashplugin-nonfree/manifest.json
    chmod 644 /usr/lib/pepperflashplugin-nonfree/manifest.json
cd ..

Just copy and save it as make the file executable

chmod +x

and execute it in terminal via sudo.

It was the edit part, thanks :slight_smile: