Can't connect to wireless

A friend of mine gave me a Netrunner/Linux Distro disc 2014.
I decided to try it just to get away from using Micro Soft Operating
system. I tried to use it right from the disc. No problem. BUT I CAN’T
CONNECT to the internet. My land lord lets me use his wireless
connection. I type in the code but nothing happens.
I can connect just fine when using Micro Soft Operating
system but I CAN’T connect with Netrunner. I also tried Ubuntu and the
same situation applies.: CANNOT connect to wireless. It looks like I am

Is there a fix for this? The person who gave me the disc says even if I DON’T
work off the disc, and just worn load it onto my hard drive I will probably
have the same issues. Am I going to be stuck with this krappy Micro Soft
operating system?

What can I do?

Can you give use the exact name of your wireless card ?
The terminal command (just open a Terminal/Konsole and type in the following and post its output)

lspci -nn | grep -i network

should show the exact network card names in your system.
In the good case just some driver (or the firmware) is missing and needs to be installed for your wireless card to work.