Can't detect wireless networks - SOLVED

The problem: I can’t connect to wi-fi, the 2 icons on the left of the airplane icon (I guess one of them represents wireless connection, I don’t know what others mean) are grey and when I click them, nothing changes.

Card: Qualcomm Atheros AR9485
Driver: ath9k

The card is detected and the driver is loaded - I checked these. But I don’t even see a list of wi-fi connections. When I start the computer, for about 2-3 seconds I have the option to click on the wireless icon and activate it. But before it lists any connection, for some reason, it gets deactivated and becomes grey.

Ethernet works fine.
I searched on the internet, found some options, entered some commands in the terminal and tried to make the wireless work, but it seems it’s not configured. :huh:

Another laptop, running Netrunner 13.12, connects to the wireless network without any problem (but it has a different card too).
So, what can I do?

Test eliminated; reboot and reinstalling; placed in a terminal:

$ sudo apt-get remove --purge bcmwl-kernel-source

$ sudo reboot

Connect the ethernet cable and put in a terminal:

$ sudo apt-get install firmware-b43-installer

$ sudo reboot


Alternate Method

Step 1: First download “dkms” package :

Navigate to the directory where dkms package is present using “cd” command and
install it using the following command.

$ cd folder_name
$ sudo dpkg -i dkms*.deb

Step 2: Now Download “bcmwl-kernel-source” :

and install it using following command.

$ sudo dpkg -i bcmwl*.deb

$ sudo reboot

Thank you, Ghermain.
I found (almost accidentally) this thread on Ubuntu forums:
And this code solved my problem:

echo "options asus_nb_wmi wapf=1" | sudo tee /etc/modprobe.d/asus_nb_wmi.conf

So, I didin’t need to enter the command you posted, but again, thank you. Now I’ll mark the thread as solved.