Can't Get Past Log In

I am a bit of a noob when it comes to Linux so I apologize if I overlooked something, but for some reason I can’t get past the log in screen. Now to give a bit of context this is a fresh install and I have not been able to log in at all. It worked fine off the flash drive and the ISO was not corrupt (I used rufus for the bootable flash drive), but once it had installed and I restarted it would not go past log in. When I entered the password the screen would go black for a second or two and then immediately go back to the log in. Now I only made a root and boot/efi partition I doubt that has anything to do with it, but I haven’t done much with partitioning before.

Specs of the machine.
ASRock Z77-E ITX
AMD Radeon HD7950
Crucial MX100 256GB (OS Drive)
WD 1TB (Storage)

Can you check if there is enough free disc space on the partition you created. When the desktop fails to load it might jump back to the login screen.

Maybe you could try to login from tty, on the login screen press crtl+alt+f1 and then enter your username and password and try to start DE by typing startx

Okay I was able to get to the DE from tty thanks for that emptybb. Now any idea what would cause this or is this normal after installing? I doubt that it is, but as I said bit of a noob.

Did you get the Plymouth splash screen?

I don’t believe so.

I think that its SDDM again causing problems, so you can try to disable it like I wrote on this thread

I’ve got 6 machines all running Netrunner rolling and not one has an issue with SDDM.

What is you video card?

I had my specs in the first post, but will just repeat an AMD Radeon HD 7950. Also tried the code you linked empty, but it didn’t work and now it won’t shut off. Tried reenabling SDDM, but that did not fix it. The auto login for SDDM appears to have fixed the login problem.

Sorry brain fart, your system settings didn’t register in my head first time around.

Netrunner Rolling is based on Manjaro and Thus their installer which uses a hybrid ISO.

I see you used rufus which extract’s the ISO to a fat32 file system like unetbootin does, this method doesn’t install properly.

The best way to make a bootable Manjaro based USB is with DD, or anything else that makes a USB CD/DVD read-only file system partition on the stick.

Hmm did not know that it’s been about a year since I last made a bootable flash drive of Manjaro to try and it was with unetbootin, but it did work. Anyway finished the reinstall same issue, still no plymouth, but it did fix some of the weird system issues I started seeing after messing around with it a bit more. The no plymouth bothers me a bit I can work around SDDM by switching to KDM or just keep using tty/auto login, but I also noticed it isn’t always booting in sometimes it freezes before getting to SDDM and requires a restart.

Edit: Also, Steam crashes the OS whenever I attempt to open it just found that out.

Did you check the md5 sum of the iso you downloaded?
It sounds to me that something there is broken

Because of Plymouth not showing I believe this to be a graphics driver issue and not an SDDM problem.

Did you install using the free or the non-free boot option on the live media?

Manjaro has been having a few issues with the latest catalyst and Nvidia proprietary drivers.

Also, did you run the initial updates to your system before the issue started or was it right after the install?

sudo pacman -Syyu

I’m thinking this could also be related to the bash updates if you did.

I checked the MD5 sum before posting here and it’s fine. As for what drivers I am using I believe I am on the free drivers. The issue started immediately after installation hadn’t installed any updates yet, and installing updates didn’t change anything.

Do you have hybrid graphics?

If not go into the Menu > Settings > Manjaro Settings Manager > Hardware Detection to see what drivers you have installed and to switch to the other ones.

Here is a screen shot of the utility I’m talking about:

Okay I downloaded the proprietary ones and switched to them I now see Plymouth before logging in only problem is I can’t get to the DE now lol. The error is coming from x window by the looks of it believe it said it was already running a server for the display.

Man, you’ve got allot of issues going on with that system don’t you. :wink:

Did you use the Manjaro Hardware Detection Utility posted above to do this?

If not what method did you use to install proprietary drivers?

Note: Please keep in mind that that Manjaro graphics stack is different than Arch Linux and that the Arch method WILL fail.

Ya… I am enjoying it though. Honestly besides the can’t log in from the start and Steam just crashing it those were the only issues I had run into. I installed the proprietary drivers from the Manjaro Hardware Detection Utility and checked with lspci -k the drivers are correct I believe.

Did you run today’s update yet?
I would do that and also do a complete system reboot.