can't play or delete network share files

I can’t delete, move or play files locally from my network hard drive. It auto-connects via samba at boot. I can add files to it. When I try to delete i get " resource busy" error. It hangs saying “deleting file” but never progresses. This happens sporadically. Sometimes it works, sometimes not. When I try to transfer a file from one folder to another within the drive i get something like " cannot change file name." Last, i can’t get any video player program to play a file from the drive locally on my computer. I know this is three issues. But maybe there are related and could indicate the larger issue.
Netrunner Enigma 1 KDE and Seagate 2TB network attached storage.

Hi darinboue, let’s try to get a larger picture:
Do you use wifi or wired network connection?
Did you use “sambamounter” to connect your network drive?
If so, can you make a screenshot of sambamounter config?

Wired connection
I mount it through the gui. Where do I get the config output?

By Sambamounter I mean this tool:
So it adds a Link in Network Folder to your mounted Network Folder.
This is different than other methods, as it enables locally playing and storing back files, which otherwise programs might complain about.

Yes, I go to Network Drives, Samba Shares, Seagate Group, Goflex Home, it asks for user and password, then to the folder. It adds a link to the folder in the Places side menu just under Home, Network, etc. It is automatically there when I boot up. I can open it and transfer files to it. Moving files around in it and deleting is problematic. ( I solved the vlc playing files from it issue in the vlc settings)

Which VLC settings solved the goflex playing issue for you?

VLC preferences, show settings: all, input/codecs, access modules, SMB - put in the username and password for your network drive, save. Now VLC has permission to play files from the network drive. close and reopenvlc and it worked. don’t think i had to reboot

Still have the issues of deleting and transferring. Sometimes I can.delete.or.move a file, sometimes not. Alsk, if I.try to transfer any more than two.files at a time from the computer to the NAS, one.will always freeze mid.transfer.