Can't upgrade to 2014-09

Only DVD copy I had was the 2014-04 version so installed it and now won’t upgrade to latest.

Followed the readme but doesn’t work.

[quote]Known Issues:

For your first complete update, please enter the following commands:

$ sudo pacman -Syy
$ sudo pacman -S manjaro-keyring
$ sudo pacman -Suu


If you experience a certificate issue or cannot update due to “ca-certificates package error”, please execute the following command in a terminal: pacman -Syu ca-certificates --force[/quote]

Used force for certs. But after entering sudo pacman -Suu

Get hit with a lot of hit enter to say yes for packages. With end of term output saying

[quote]:: Replace shared-color-profiles with extra/colord? [Y/n]
resolving dependencies…
looking for inter-conflicts…
error: unresolvable package conflicts detected
error: failed to prepare transaction (conflicting dependencies)
:: libbaloo4 and baloo are in conflict (baloo<=4.14.0-1)[/quote]

How do I proceed?

I would suggest that you download the latest ISO follow the Manjaro instructions to create an install media.

What’s the point of Rolling if I have to Clean install every 6 months just like Ubuntu?
Found comment in RELEASE: Netrunner Rolling 2014.09.1 announcement.
That said:

sudo pacman -Suu --ignore=baloo

And everything downloaded and updated desktop boots up fine. And don’t see any issues yet.
New to learning it but any advice as learning and wondering if ignore=baloo is fine for now since I don’t have desktop search enabled.

Any other things I can check? broken? conflicts? etc…?
As mentioned everything seems to be going fine. Tho was surprised that Firefox is only version 30.

The problem is that the ISO is a snapshot of the OS at a specific point and time in it’s history. Now, if there have been any major changes in packaging or system configurations since the ISO was released, then a new one will be required for the system to work properly after initial installation, this applies to NEW installs only. Once the system has been installed and as long as you keep your system updated as they are released, you’ll not need to install it again and be fine.

I was worried about the changes that we’re made to the Manjaro graphics stack and security key’s. etc. that occurred during the period between ISO’s, but I don’t see that these we’re issues for you.

However the baloo issue will need to be addressed.

The baloo and baloo-widgets were depreciated upstream by arch and just haven’t been removed from the Manjaro repositories yet.

You’ll need to upgrade to the newer baloo4 packages as these have more functionality, bug’s were fixed and speed improvements have been applied, also the libraries and resources for akonadi were split out to their own packages.

Here is command to use:

sudo pacman -S baloo4 baloo4-akonadi baloo4-widgets libbaloo4

when asked about it replacing baloo and baloo-widgets enter yes to replace.

Also of concern will be the changes that Netrunner made to it’s boot process, as well as other fixes they made on the new ISO that we’re issues with the old one. (Examples: No Plymouth boot screen, the Account details>passwords and user information dialog freezing, the depreciated laptop-mode-tools being replaced by TLP, etc,) These are all things you’ll need to find and manually fix yourself after using the old ISO.

The firefox-kde package from the blueshell repository is at version 30, the Netrunner team is having issues compiling version 43 with the Suse KDE patches applied at the moment, once they get it compiled and tested it will be pushed to the blushell repository.

If you can’t wait then you can always install the firefox package from the Manjaro repositories until the other one gets updated.

sudo pacman -R firefox-kde sudo pacman -S firefox

Optionally, you can also try compiling and/or editing the pkgbuild file for the firefox-kde-opensuse package yourself from the AUR.

yaourt -S firefox-kde-opensuse

Thanks for the heads up and did the

sudo pacman -S baloo4 baloo4-akonadi baloo4-widgets libbaloo4

But can wait on the Firefox upgrade no biggie tho thought rolling meant closer to bleeding edge.
So still learning some more about it. As coming from SolydXK KDE based on Debian Testing.

But hoping this keeps apps fresher? As needing the latest in darktable,Gimp,Krita,etc…
Also needing the latest in tablet support in latter kernels. Tho lastest announcement says Kernel 3.14.18
After my 1.5hr upgrade kernel version shows Kernel version: 3.10.54-1

So going to do some more reading. And may have to down the latest iso?

If so and since I have a separate /home can I upgrade install from the iso for just root? and leave /home assigned but untouched? As don’t want to loose the 4hr investment of installing and setting up apps and desktop.

Thanks again for all your help and insights.

You need to upgrade the kernel manually if you want a newer major version. 3.10 is LTS so it will be updated regular aswell. The packages are called linux314 or linux3XX (version number)

There is a graphical way to manage kernels in rolling, remember this is based off of Manjaro not arch. It will only update withing the kernel series that is installed not from one series to another, To install a newer kernel open up the Manjaro Settings Manager under settings in the menu, this is where you manage kernels, drivers, language packs, etc., open up Kernel and install whatever kernel series you wish to run, reboot if all goes well you can remove 3.10, or just leave it as a backup, it’s up to you. The ability to use mere than one kernel is one of Manjaro’s biggest strengths that set it apart from Arch, the rest of the system is rolling and comes from the Manjaro repositories, manjaro is only approx 2 to 3 weeks behind Arch in package updates. The firefox-kde application is from the blueshell repository and is a Netrunner specific package.

Cool Manjaro Kernel Gui Really like that feature. Couldn’t figure out for 2 minutes why boot to desktop Netrunner was taking 667mb when my SolydK was chiming in at 420mb. Then found the Firefox pre-load startup script and unchecked that. In fact going to look into services and such. As don’t need anything Printer or Bluetooth or Laptop specific like battery,etc… Like to trim down uncessary and uneeded startup services.

Like the Homerun menu and better wireless applet. Tho really missing the volume popup showing level for mouse wheel setting on the fly have to click to see levels. And really miss yaWP weather applet in tray. Really nice weather app that doesn’t appear in the repo. And can’t find another source for installing it. Same goes for having a gmail in the tray one that allows you to play a sound file for notification like the old buggy gmail plasmoid.

Removed Thunderbird and Skype and don’t need them. Wondering how to remove Cloud Storage manager as don’t do cloud storage. Or getting rid of Marble which also don’t need. But if I remember couldn’t due to it wanting to also remove packages used by system? Like to make all these adjustments to trim down size & time on updating system.

How do I know if there are any udpates? Don’t see the Octopi icon in systray. As manjaro had a Yellow/Green indicator of updates in the pipe. And others had a right-click restart option where Netrunner only has a right click Leave with none of the others available. Or other distro’s gave the choice to have the power choices Shutdown/Restart/Logout dialog popup on desktop so I could choose which one I wanted depending on the situation.

Thought the choices for Torrent and IM where really different. As usually Ktorrent and Quassel are default in most KDE distro’s. Will have to check them out. As Ktorrent always was enough for me. And don’t IM. Gwenview had to modify get rid of the share button and add Crop,Resize,Flip and toggle thumnail bar,Save,Save As. More useful to me as the defaults.

All-in-All Quite Impressed ! a lot of customizing and crafting went into presenting a very usable,clean and many ways superior KDE spin.

Trying to free up some space on root as tight with 1.7gb free. Thought to delete packages in /var/cache/pacman/pkg/ which would give me back 1.3gb. I assume this is alright to do?
So any insights or suggestions on my listed issues which are minor would be greatly appreciated.
Thanks again to the individuals & team that make Netrunner possible. As an outstanding choice for going rolling KDE.

Wow, you’ve got allot going on there, trying to trim it down does sounds like a fun project. :slight_smile:

For a system tray update notification icon, you’ll need to install Octopi Notifier:

sudo pacman -S octopi-notifier

Thanks yep spotted that in another thread and added it.

Now only issue is my Nook Color Tablet not reconized by Calibre. Dolphin list it but can’t mount and see it.
Which worked fine in my Debian SolydK KDE setup. As kio-mtp,libmtp,mtpfs are installed but on debian also had to install mtp-tools which isn’t listed in Octopi. And wonder if my mtp device problem is related to not having mtp-tools installed?

Running mtp-detect gave me

[code][orbmiser@Winterfell ~]$ mtp-detect
Unable to open ~/.mtpz-data for reading, MTPZ disabled.libmtp version: 1.1.6

Listing raw device(s)
Device 0 (VID=18d1 and PID=2d02) is a Google Inc (for Barnes & Noble) Nook Color.
Found 1 device(s):
Google Inc (for Barnes & Noble): Nook Color (18d1:2d02) @ bus 2, dev 4
Attempting to connect device(s)
PTP_ERROR_IO: failed to open session, trying again after resetting USB interface
LIBMTP libusb: Attempt to reset device
LIBMTP PANIC: failed to open session on second attempt
Unable to open raw device 0[/code]

So more work checking out the issue. Looked at the arch-wiki mtp.

[quote]Workaround if the KDE device actions does not work

If you are not able to use the action “Open with File Manager”, you may work around this problem by editing the file /usr/share/apps/solid/actions/solid_mtp.desktop

Change the line

Exec=kioclient exec mtp:udi=%i/


Exec=dolphin “mtp:/”[/quote]

Still No joy and issue with tablet and Calibre connect.
Not a Big issue as dual boot with Win7. But an issue I like to resolve.



Did you look for your device in /usr/lib/udev/rules.d/69-libmtp.rules?

kdesu kate /usr/lib/udev/rules.d/69-libmtp.rules

if not there then add this line and save:
SUBSYSTEM==“usb”, ATTR{idVendor}==“18d1”,ATTR{idProduct}==2d02, MODE=“0666”, GROUP=“plugdev”

Was already there

# Google Inc (for Barnes & Noble) Nook Color ATTR{idVendor}=="18d1", ATTR{idProduct}=="2d02", SYMLINK+="libmtp-%k", ENV{ID_MTP_DEVICE}="1", ENV{ID_MEDIA_PLAYER}="1"

But went ahead and added your line to bottom. Subsystem “usb”? as is a Mtp device.

SUBSYSTEM=="usb", ATTR{idVendor}=="18d1",ATTR{idProduct}==2d02, MODE="0666", GROUP="plugdev"

Still no joy presenting same issue. Long try reading device.

Then a Fail

Strange as must have worked maybe with a Stock Nook Color as I have rooted Emmc with Cyanogen CM10 to make it into a more regualar tablet. But no issue with Ubuntu based distro’s or Debian KDE system.

Yea, I don’t use MTP anymore, sometimes it works and sometimes it don’t, and when it don’t it’s very hard to figure out why. I finally gave up on MTP last year and started to use my card reader for my camera’s and KDE connect on my phone and tablet.

Yeah the mtp standard has so many exceptions and buggy implementations that I would recommend using something else whenever possible.