Chromium and Magnet Links on Netrunner


When you click on a magnet link in chromium in Netrunner rolling…it asks to either ‘do nothing’ or to ‘launch application’. Of course, I want it to automatically launch transmission-qt and put the magnet link inside of it. I’ve attempted the following to get transmission-qt to launch for these magnet links:

[devnet@lostnix applications]$ xdg-mime default transmission-qt.desktop x-scheme-handler/magnet
[devnet@lostnix applications]$ xdg-mime query default x-scheme-handler/magnet

So, I know that transmission-qt.desktop is the default application and it is set. However, when I click on a magnet link and tell Chromium to ‘Launch Application’ it does NOTHING. No program launch, no nothing.

I figured I’d give Chromium an entry in ~/.local/share/applications/mimeapps.list so I opened that puppy up and put the following in there:

[Default Applications]:

Restarted Chrome and tried it…still does nothing with magnet links.
Restarted entire PC and tried it…still does nothing with magnet links.

So, there is something drastically wrong with xdg-open when it comes to link handling and KDE…this works fine in openbox on the same exact PC. Anyone out there know of a solution? I’ve exhausted 2 hours of my life and I have strong Google-Fu…

This is known issue with chromium for a while now. Look at the first answer in the folloeing link to fix this issue, just substitute transmission-gtk for transmission-qt

Yes, I ran across this. It’s rather crude to fix it this way I think so I’ll just wait for a fix to come out. Plus our version of xdg-open is completely different and 50 times more complicated than any that people refer to in these fix posts :slight_smile: