Connect to OpenVPN

Hello folks,

I just migrated from Ubuntu to Netrunner as I’ve heard good things about Arch and Netrunner seems like a good choice for someone with low knowledge of Linux.

I want to connect to a VPN network via the OpenVPN protocol. I have imported the .ovpn with TrustedRoot.pem, added username and password:

The Network Manager also shows that I’m connected to my VPN server:

However, it doesn’t work and I’m surfing via normal connection. Is it a problem of the tun0 connection? (I didn’t have that with my Ubuntu installation and OpenVPN worked fine.)

Thanks for your help.

Did you check if the dns was correctly set?
On the command-line you could try

sudo dhclient tun0

Or manually check or set the dns via network-manager plasmoid.

Thanks for your anwer.

I do not know how to set DNS and where I can find the appropriate DNS. Using the same process under Ubuntu just worked fine without having to do anything further.


sudo dhclient tun0

I don’t get any output. What is the network-manager plasmoid, is it the default network manager applet?

Can you elaborate, Leszek?

Strangely, the WebUI of my VPN provider tells me that I’m connected via VPN but my IP is still wrong.

Network-manager plasmoid is the default networkmanager on Netrunner.
If the above command doesn’t give any output that means the command ran successfully.

However it’s strange that you say that you have the wrong ip address though connected with the VPN. Did you tried reconnecting?
Maybe the OpenVPN needs a special proxy set.

Did You install the networkmanager-openvpn package first?
without this package the openvpn protocol won’t work.

Yep yep!

AFAIK I don’t need a proxy for the OpenVPN connection but I have asked the same question at the community forum of my VPN provider perhaps they can enlighten me.

I’ve never used openvpn so i’m not sure how that works.
However you should be able to download your key from openvpn and import it here:

This may also be of some help:

Yes it should work like that. A new feature after doing this, is that it will ask you to make a copy of the certificate to ~/.kde4/share/apps/networkmanagement/certificates/ and it will split it automatically. Maybe he can try that.

You can tryout vpnbook for free (password changes every other day I think) , i use the xxxxudp25000.ovpn certificates, and no issues there. Not long ago I tested Froot vpn, it connected, but my ip never changed.

OK, the networkmanager-openvpn package is ONLY for use with OpenVPN, for other types of VPN encription schemes, etc. you would need the appropriate packages.

Here is what is available in the Manjaro Repositories:
networkmanager-openconnect – NetworkManager VPN integration for openconnect
networkmanager-openvpn – NetworkManager VPN plugin for OpenVPN
networkmanager-pptp – NetworkManager VPN plugin for pptp
networkmanager-vpnc – NetworkManager VPN plugin for vpnc

For other uses there is:
networkmanager-dispatcher-openntpd – Dispatcher Script for openntpd
networkmanager-dispatcher-sshd – Dispatcher Script for sshd

More plugin/dispatcher packages can be found in the AUR as well.