Connecting to a hidden network?

I’ve added the hidden network that I need to connect to the kconnection editor and I still cannot see it or connect, any ideas on how to do this?

Thank You!
Ok, after adding it I did a restart of my system as I had a weird widget problem happening on the panel and now it’s connected, so apparently that might be a way to do it until there is a connect to hidden network option.